summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-28 15:43:00 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-05-02 07:45:27 -0400
commitad8ee53cb17b8d4cb1ff85f8feae62ab1c0f36ab (patch)
treec7ad8ae5ec717df9ed85eec94d5bf876c03ae913 /gnu/packages/python-xyz.scm
parentcaf84530e0a85d5ad4091582832ac303cfc14abe (diff)
downloadguix-patches-ad8ee53cb17b8d4cb1ff85f8feae62ab1c0f36ab.tar
guix-patches-ad8ee53cb17b8d4cb1ff85f8feae62ab1c0f36ab.tar.gz
gnu: Add python-mkdocs.
* gnu/packages/python-xyz.scm (python-mkdocs): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec45958134..d076fa1c16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -290,6 +290,42 @@ It indexes documents and provides a search interface for retrieving documents
that best match text queries.")
(license license:expat)))
+(define-public python-mkdocs
+ (package
+ (name "python-mkdocs")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (pypi-uri "mkdocs" version))
+ (sha256
+ (base32 "0fgv5zawpyyv0vd4j5y8m4h058lh9jkwfcm0xy4pg7dr09a1xdph"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Requirements refer to a specific version of dependencies,
+ ;; which are too old. So we patch to refer to any later version.
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("==") ">=")))))))
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-jinja2" ,python-jinja2)
+ ("python-livereload" ,python-livereload)
+ ("python-lunr" ,python-lunr)
+ ("python-markdown" ,python-markdown)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://www.mkdocs.org")
+ (synopsis "Project documentation with Markdown")
+ (description "MkDocs is a static site generator geared towards building
+project documentation. Documentation source files are written in Markdown, and
+configured with a single YAML configuration file.")
+ (license license:bsd-3)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")