summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-28 15:23:13 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-05-02 07:45:27 -0400
commitcaf84530e0a85d5ad4091582832ac303cfc14abe (patch)
tree9865d54e774939ddfd14938a78f643d76a1d6945 /gnu/packages/python-xyz.scm
parentedc946dde3dee28b63e87bf166ac4064f84203b5 (diff)
downloadguix-patches-caf84530e0a85d5ad4091582832ac303cfc14abe.tar
guix-patches-caf84530e0a85d5ad4091582832ac303cfc14abe.tar.gz
gnu: Add python-lunr.
* gnu/packages/python-xyz.scm (python-lunr): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9dc191dcb5..ec45958134 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -265,6 +265,31 @@ as functions or string constants to form colored terminal output.")
during long operations.")
(license license:expat)))
+(define-public python-lunr
+ (package
+ (name "python-lunr")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (pypi-uri "lunr" version))
+ (sha256
+ (base32 "106akalywfmnypzkdrhgz4n4740a8xayspybsw59kq06vz8i2qrc"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-nltk" ,python-nltk-3.4)))
+ (home-page
+ "https://github.com/yeraydiazdiaz/lunr.py")
+ (synopsis "Full-text search library")
+ (description "This package provides python library for full-text search.
+It indexes documents and provides a search interface for retrieving documents
+that best match text queries.")
+ (license license:expat)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")