summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-07-23 20:48:19 +0800
committerLudovic Courtès <ludo@gnu.org>2022-08-06 23:14:42 +0200
commit515288874ff12c00ca8d1d22a94ef4b4903fec76 (patch)
treec17d669711af652d74a80211e95d47bf71311efb /gnu/packages/python-xyz.scm
parent86da72fb5b3a35a30660e81084ed0c90ec5af08f (diff)
downloadguix-patches-515288874ff12c00ca8d1d22a94ef4b4903fec76.tar
guix-patches-515288874ff12c00ca8d1d22a94ef4b4903fec76.tar.gz
gnu: Add i3-autotiling.
* gnu/packages/python-xyz.scm (i3-autotiling): New variable. Signed-off-by: Hilton Chain <hako@ultrarare.space> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index affc4772dd..b6ca32a757 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30329,3 +30329,27 @@ compatible with BibTeX's own parser.")
"This package provides a Python library for controlling the i3 and Sway
window managers.")
(license license:bsd-3)))
+
+(define-public i3-autotiling
+ (package
+ (name "i3-autotiling")
+ (version "1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nwg-piotr/autotiling")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hjlvg7095s322gb43r9g7mqlsy3pj13l827jpnbn5x0918rq9rr"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ;no tests
+ (native-inputs (list python-wheel))
+ (propagated-inputs (list python-i3ipc))
+ (home-page "https://github.com/nwg-piotr/autotiling")
+ (synopsis "Automatically tile windows in i3 and Sway")
+ (description
+ "Script for Sway and i3 to automatically switch the horizontal/vertical
+ window split orientation.")
+ (license license:gpl3)))