summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-07-23 20:46:53 +0800
committerLudovic Courtès <ludo@gnu.org>2022-08-06 23:14:42 +0200
commit86da72fb5b3a35a30660e81084ed0c90ec5af08f (patch)
treeeef127c16e3229c921c8e6629892c3bfaf2bb8b9 /gnu/packages/python-xyz.scm
parent80ac0c0a7e557ac510ce81606be99194df40a1c7 (diff)
downloadguix-patches-86da72fb5b3a35a30660e81084ed0c90ec5af08f.tar
guix-patches-86da72fb5b3a35a30660e81084ed0c90ec5af08f.tar.gz
gnu: Add python-i3ipc.
* gnu/packages/python-xyz.scm (python-i3ipc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95467f4d52..affc4772dd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -126,6 +126,7 @@
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Marek Felšöci <marek@felsoci.sk>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30305,3 +30306,26 @@ compatible with BibTeX's own parser.")
;; N.B. It seems the parser was translated from WEB by hand: this
;; package does not contain any generated files.
(license license:expat))))
+
+(define-public python-i3ipc
+ (package
+ (name "python-i3ipc")
+ (version "2.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/altdesktop/i3ipc-python")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13bzs9dcv27czpnnbgz7a037lm8h991c8gk0qzzk5mq5yak24715"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ;FIXME: some tests are unable to run
+ (propagated-inputs (list python-xlib))
+ (home-page "https://github.com/altdesktop/i3ipc-python")
+ (synopsis "Python library for controlling i3 and Sway")
+ (description
+ "This package provides a Python library for controlling the i3 and Sway
+window managers.")
+ (license license:bsd-3)))