summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:51:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:50 -0400
commiteb13c73ce271c8566a7a4fafdbc00d2997dd3740 (patch)
tree1da17399c9c335348afd0a8770cbfd90f938e24a /gnu/packages/python-web.scm
parentc0e3ba2904f5fbaa105d54f4a5a920e04caff629 (diff)
downloadguix-patches-eb13c73ce271c8566a7a4fafdbc00d2997dd3740.tar
guix-patches-eb13c73ce271c8566a7a4fafdbc00d2997dd3740.tar.gz
gnu: Remove python2-urllib3.
* gnu/packages/python-web.scm (python2-urllib3): Delete variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d5132670d5..b0454b6f81 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2983,17 +2983,8 @@ addon for removing tracking fields from URLs.")
"Urllib3 supports features left out of urllib and urllib2 libraries. It
can reuse the same socket connection for multiple requests, it can POST files,
supports url redirection and retries, and also gzip and deflate decoding.")
- (properties `((python2-variant . ,(delay python2-urllib3))))
(license license:expat)))
-(define-public python2-urllib3
- (let ((base (package-with-python2 (strip-python2-variant python-urllib3))))
- (package/inherit
- base
- (propagated-inputs
- `(("python-ipaddress" ,python2-ipaddress)
- ,@(package-propagated-inputs base))))))
-
(define-public awscli
(package
;; Note: updating awscli typically requires updating botocore as well.