summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:22:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:22:53 +0300
commite2ba910e38eadcedf22645d8ecfcb4bb45f4701a (patch)
tree371e8aa79184dc3d7b4c98fb722f828c0181fa0c /gnu/packages/python-web.scm
parentf3d446ccf4719f9e44d091f84d530bf09b7329c7 (diff)
downloadguix-patches-e2ba910e38eadcedf22645d8ecfcb4bb45f4701a.tar
guix-patches-e2ba910e38eadcedf22645d8ecfcb4bb45f4701a.tar.gz
gnu: Add python-zope-security-bootstrap.
* gnu/packages/python-web.scm (python-zope-security-bootstrap): New hidden package.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 81cee4dad3..b602119053 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1389,6 +1389,18 @@ Zope3, which are are special objects that have a structural location.")
security policies on Python objects.")
(license license:zpl2.1)))
+(define-public python-zope-security-bootstrap
+ (package
+ (inherit python-zope-security)
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-zope-proxy" ,python-zope-proxy-bootstrap)
+ ("python-zope-schema" ,python-zope-schema)))
+ (native-inputs `())
+ (properties `((hidden? . #t)))))
+
(define-public python2-zope-security
(package-with-python2 python-zope-security))