summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-20 01:53:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-20 04:49:51 +0100
commit63b066709bb01a382325ce7b3b863ba2b68599bc (patch)
treebe66cf5eb466fb4598128dac8f3d432932cc42cd /gnu/packages/python-web.scm
parent21de4160d3bc866cb832d12e98acc2bc38a59a5f (diff)
downloadguix-patches-63b066709bb01a382325ce7b3b863ba2b68599bc.tar
guix-patches-63b066709bb01a382325ce7b3b863ba2b68599bc.tar.gz
gnu: Update pythonpaste.org home pages.
* gnu/packages/check.scm (python-scripttest)[home-page]: Update URI. * gnu/packages/python-web.scm (python-paste, python-pastescript) (python-webtest, python-pastedeploy)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7f365e3506..7808b7631e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1679,7 +1679,7 @@ and to spawn subprocesses to handle requests.")
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
- (home-page "http://pythonpaste.org/deploy/")
+ (home-page "https://pylonsproject.org/")
(synopsis
"Load, configure, and compose WSGI applications and servers")
(description
@@ -1712,7 +1712,7 @@ file.")
("python-webob" ,python-webob)
("python-six" ,python-six)
("python-beautifulsoup4" ,python-beautifulsoup4)))
- (home-page "http://webtest.pythonpaste.org/")
+ (home-page "https://docs.pylonsproject.org/projects/webtest/")
(synopsis "Helper to test WSGI applications")
(description "Webtest allows you to test your Python web applications
without starting an HTTP server. It supports anything that supports the
@@ -2894,7 +2894,7 @@ available in Django, but is a standalone package.")
("python-nose" ,python-nose)))
(propagated-inputs
`(("python-six" ,python-six)))
- (home-page "http://pythonpaste.org")
+ (home-page "https://pythonpaste.readthedocs.io/")
(synopsis
"Python web development tools, focusing on WSGI")
(description
@@ -2923,7 +2923,8 @@ follows ideas flowing from WSGI (Web Standard Gateway Interface).")
(propagated-inputs
`(("python-paste" ,python-paste)
("python-pastedeploy" ,python-pastedeploy)))
- (home-page "http://pythonpaste.org/script/")
+ (home-page (string-append "https://web.archive.org/web/20161025192515/"
+ "http://pythonpaste.org/script/"))
(arguments
'(;; Unfortunately, this requires the latest unittest2,
;; but that requires traceback2 which requires linecache2 which requires