summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm3
-rw-r--r--gnu/packages/python-web.scm9
2 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 41b0c88ef9..5554965a06 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1021,7 +1021,8 @@ timeout has been exceeded.")
(build-system python-build-system)
(native-inputs
`(("python-pytest" ,python-pytest)))
- (home-page "http://pythonpaste.org/scripttest/")
+ (home-page (string-append "https://web.archive.org/web/20161029233413/"
+ "http://pythonpaste.org/scripttest/"))
(synopsis "Python library to test command-line scripts")
(description "Scripttest is a Python helper library for testing
interactive command-line applications. With it you can run a script in a
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7f365e3506..7808b7631e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1679,7 +1679,7 @@ and to spawn subprocesses to handle requests.")
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
- (home-page "http://pythonpaste.org/deploy/")
+ (home-page "https://pylonsproject.org/")
(synopsis
"Load, configure, and compose WSGI applications and servers")
(description
@@ -1712,7 +1712,7 @@ file.")
("python-webob" ,python-webob)
("python-six" ,python-six)
("python-beautifulsoup4" ,python-beautifulsoup4)))
- (home-page "http://webtest.pythonpaste.org/")
+ (home-page "https://docs.pylonsproject.org/projects/webtest/")
(synopsis "Helper to test WSGI applications")
(description "Webtest allows you to test your Python web applications
without starting an HTTP server. It supports anything that supports the
@@ -2894,7 +2894,7 @@ available in Django, but is a standalone package.")
("python-nose" ,python-nose)))
(propagated-inputs
`(("python-six" ,python-six)))
- (home-page "http://pythonpaste.org")
+ (home-page "https://pythonpaste.readthedocs.io/")
(synopsis
"Python web development tools, focusing on WSGI")
(description
@@ -2923,7 +2923,8 @@ follows ideas flowing from WSGI (Web Standard Gateway Interface).")
(propagated-inputs
`(("python-paste" ,python-paste)
("python-pastedeploy" ,python-pastedeploy)))
- (home-page "http://pythonpaste.org/script/")
+ (home-page (string-append "https://web.archive.org/web/20161025192515/"
+ "http://pythonpaste.org/script/"))
(arguments
'(;; Unfortunately, this requires the latest unittest2,
;; but that requires traceback2 which requires linecache2 which requires