summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 11:01:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 11:01:41 +0300
commitd76e0a36f93b41bac2d42b85fa80079784cd0b76 (patch)
treecd0182f5228a94fde5f7cc372172bf86b6735e3b /gnu/packages/python-check.scm
parentc2179c27fe16314ee53a1a0a8a528c2e36f6e8a4 (diff)
downloadguix-patches-d76e0a36f93b41bac2d42b85fa80079784cd0b76.tar
guix-patches-d76e0a36f93b41bac2d42b85fa80079784cd0b76.tar.gz
gnu: python-pytest-toolbox: Honor #:tests? flag.
* gnu/packages/python-check.scm (python-pytest-toolbox)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 7c2920fabe..9ae697d85f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1129,12 +1129,13 @@ service processes for your tests with pytest.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "setup.cfg"
- ((".*timeout.*") ""))
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (substitute* "setup.cfg"
+ ((".*timeout.*") ""))
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-pydantic" ,python-pydantic)
("python-pytest" ,python-pytest)