summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 10:59:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 10:59:33 +0300
commitc2179c27fe16314ee53a1a0a8a528c2e36f6e8a4 (patch)
treeae637170302d7492f363e6df1befac1c3d1d06ef /gnu/packages/python-check.scm
parenta41f93c39d03143ce9007ad278a04fa30498bc0b (diff)
downloadguix-patches-c2179c27fe16314ee53a1a0a8a528c2e36f6e8a4.tar
guix-patches-c2179c27fe16314ee53a1a0a8a528c2e36f6e8a4.tar.gz
gnu: python-pytest-toolbox: Fix test suite.
* gnu/packages/python-check.scm (python-pytest-toolbox)[arguments]: Adjust custom 'check phase to remove obsolete pytest flag. [native-inputs]: Remove python-coverage, python-docutils, python-flake8, python-isort, python-pyflakes, python-pygments, python-pytest-cov, python-pytest-mock, python-pytest-sugar.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d1e389213c..7c2920fabe 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1130,22 +1130,15 @@ service processes for your tests with pytest.")
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "setup.cfg"
+ ((".*timeout.*") ""))
;; Make the installed plugin discoverable by Pytest.
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv"))))))
(native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-docutils" ,python-docutils)
- ("python-flake8" ,python-flake8)
- ("python-isort" ,python-isort)
- ("python-pydantic" ,python-pydantic)
- ("python-pyflakes" ,python-pyflakes)
- ("python-pygments" ,python-pygments)
+ `(("python-pydantic" ,python-pydantic)
("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-isort" ,python-pytest-isort)
- ("python-pytest-mock" ,python-pytest-mock)
- ("python-pytest-sugar" ,python-pytest-sugar)))
+ ("python-pytest-isort" ,python-pytest-isort)))
(home-page "https://github.com/samuelcolvin/pytest-toolbox")
(synopsis "Numerous useful plugins for Pytest")
(description