summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 17:56:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-30 18:29:56 +0200
commitc7d5e1a24c4805f02b7d9dd87cc8810264bdc7d2 (patch)
tree23159435ab27af79601cc43a7504c725cd0a3dad /gnu/packages/python-check.scm
parent43a6152432259865e489fa4a62ce94e33376bf79 (diff)
downloadguix-patches-c7d5e1a24c4805f02b7d9dd87cc8810264bdc7d2.tar
guix-patches-c7d5e1a24c4805f02b7d9dd87cc8810264bdc7d2.tar.gz
gnu: Add python-pytest-tornasync.
* gnu/packages/python-check.scm (python-pytest-tornasync): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 8577c8a15c..b8d63b8479 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1133,6 +1133,38 @@ also ensuring that the notebooks are running without errors.")
"This package provides a pytest plugin for testing console scripts.")
(license license:expat)))
+(define-public python-pytest-tornasync
+ (package
+ (name "python-pytest-tornasync")
+ (version "0.6.0.post2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-tornasync" version))
+ (sha256
+ (base32
+ "0pdyddbzppkfqwa7g17sdfl4w2v1hgsky78l8f4c1rx2a7cvd0fp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ; TODO: fails at "from test import MESSAGE, PAUSE_TIME"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "--verbose")))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://github.com/eukaryote/pytest-tornasync")
+ (synopsis "Pytest plugin for testing Tornado code")
+ (description
+ "This package provides a simple pytest plugin that provides some helpful
+fixtures for testing Tornado (version 5.0 or newer) apps and easy handling of
+plain (undecoratored) native coroutine tests.")
+ (license license:expat)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")