summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 17:56:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-30 18:29:56 +0200
commit43a6152432259865e489fa4a62ce94e33376bf79 (patch)
tree36f20a20df623b24f6401722989347214d0969fa /gnu/packages/python-check.scm
parentd84ead81743cc76778241c73ac02c8c6c7e8f7ce (diff)
downloadguix-patches-43a6152432259865e489fa4a62ce94e33376bf79.tar
guix-patches-43a6152432259865e489fa4a62ce94e33376bf79.tar.gz
gnu: Add python-pytest-console-scripts.
* gnu/packages/python-check.scm (python-pytest-console-scripts): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 038ca177af..8577c8a15c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1100,6 +1100,39 @@ also ensuring that the notebooks are running without errors.")
"This pytest plugin provides fixtures to simplify Flask app testing.")
(license license:expat)))
+(define-public python-pytest-console-scripts
+ (package
+ (name "python-pytest-console-scripts")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-console-scripts" version))
+ (sha256
+ (base32
+ "073l2cz11013dl30zjr575ms78j9b2bsbdl1w0gmig37spbkh8aa"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "--verbose"
+ ;; This one test fails because of PATH assumptions
+ "-k" "not test_elsewhere_in_the_path")))))))
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/kvas-it/pytest-console-scripts")
+ (synopsis "Pytest plugin for testing console scripts")
+ (description
+ "This package provides a pytest plugin for testing console scripts.")
+ (license license:expat)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")