summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 12:03:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commit7d5ffecba54c08e0fd5a492b3da67d184eb78aa9 (patch)
treeae1764b2076bbbbc3b26a7f2ccd2c52e49377685 /gnu/packages/python-check.scm
parent21e2c559450ba2076b50a6a8158db22a6322f57c (diff)
downloadguix-patches-7d5ffecba54c08e0fd5a492b3da67d184eb78aa9.tar
guix-patches-7d5ffecba54c08e0fd5a492b3da67d184eb78aa9.tar.gz
gnu: Add python-pytest-fixture-config.
* gnu/packages/python-check.scm (python-pytest-fixture-config): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d3f8520732..70140ded69 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -191,3 +191,25 @@ compliance.")
"This package provides assorted shell and environment tools for the
py.test testing framework.")
(license license:expat)))
+
+(define-public python-pytest-fixture-config
+ (package
+ (name "python-pytest-fixture-config")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-fixture-config" version))
+ (sha256
+ (base32
+ "13i1qpz22w3x4dmw8vih5jdnbqfqvl7jiqs0dg764s0zf8bp98a1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-git" ,python-setuptools-git)))
+ (home-page "https://github.com/manahl/pytest-plugins")
+ (synopsis "Fixture configuration utils for py.test")
+ (description
+ "This package provides fixture configuration utilities for the py.test
+testing framework.")
+ (license license:expat)))