summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 12:03:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commit21e2c559450ba2076b50a6a8158db22a6322f57c (patch)
treed1389a74329955895e78e062378071e866e244e4 /gnu/packages/python-check.scm
parent3b89476b709c788e90ad6600a850ab06998cfc70 (diff)
downloadguix-patches-21e2c559450ba2076b50a6a8158db22a6322f57c.tar
guix-patches-21e2c559450ba2076b50a6a8158db22a6322f57c.tar.gz
gnu: Add python-pytest-shutil.
* gnu/packages/python-check.scm (python-pytest-shutil): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 95e10e6381..d3f8520732 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -151,3 +151,43 @@ of the project to ensure it renders properly.")
"This package provides a pytest plugin for efficiently checking PEP8
compliance.")
(license license:bsd-3)))
+
+(define-public python-pytest-shutil
+ (package
+ (name "python-pytest-shutil")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-shutil" version))
+ (sha256
+ (base32
+ "0q8j0ayzmnvlraml6i977ybdq4xi096djhf30n2m1rvnvrhm45nq"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (mkdir "/tmp/bin")
+ (substitute* "tests/integration/test_cmdline_integration.py"
+ (("dirname = '/bin'")
+ "dirname = '/tmp/bin'")
+ (("bindir = os.path.realpath\\('/bin'\\)")
+ "bindir = os.path.realpath('/tmp/bin')"))
+ #t)))))
+ (propagated-inputs
+ `(("python-contextlib2" ,python-contextlib2)
+ ("python-execnet" ,python-execnet)
+ ("python-pathpy" ,python-pathpy)
+ ("python-termcolor" ,python-termcolor)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-git" ,python-setuptools-git)))
+ (home-page "https://github.com/manahl/pytest-plugins")
+ (synopsis "Assorted shell and environment tools for py.test")
+ (description
+ "This package provides assorted shell and environment tools for the
+py.test testing framework.")
+ (license license:expat)))