summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-23 15:23:25 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commit4202af69b4e2ada5da3a8744dcd97d8a2fbf46e0 (patch)
tree19c3630cf5c00006a6dab797373cd78b8837dd54 /gnu/packages/python-check.scm
parent5bec698d47361c174c1d93a44500d498ff44644d (diff)
downloadguix-patches-4202af69b4e2ada5da3a8744dcd97d8a2fbf46e0.tar
guix-patches-4202af69b4e2ada5da3a8744dcd97d8a2fbf46e0.tar.gz
gnu: Add python-pytest-filter-subpackage.
* gnu/packages/python-check.scm (python-pytest-filter-subpackage): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 38f6501fb0..5647de98c7 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -180,6 +180,41 @@ are too large to conveniently hard-code them in the tests.")
advanced doctest support and enables the testing of reStructuredText files.")
(license license:bsd-3)))
+(define-public python-pytest-filter-subpackage
+ (package
+ (name "python-pytest-filter-subpackage")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-filter-subpackage" version))
+ (sha256
+ (base32 "1s4s2kd31yc65rfvl4xhy8xx806xhy59kc7668h6b6wq88xgrn5p"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; One test is failing. There's an issue reported upstream. See
+ ;; https://github.com/astropy/pytest-filter-subpackage/issues/3.
+ ;; Disable it for now.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k" "not test_with_rst"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-doctestplus"
+ ,python-pytest-doctestplus)))
+ (home-page "https://github.com/astropy/pytest-filter-subpackage")
+ (synopsis "Pytest plugin for filtering based on sub-packages")
+ (description
+ "This package contains a simple plugin for the pytest framework that
+provides a shortcut to testing all code and documentation for a given
+sub-package.")
+ (license license:bsd-3)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")