summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-23 15:23:24 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commit5bec698d47361c174c1d93a44500d498ff44644d (patch)
tree4b474275e99e27f64801992b35c3d98050f7b519 /gnu/packages/python-check.scm
parentc0f52c41d86744537075229a9f0ec0f77ced0c75 (diff)
downloadguix-patches-5bec698d47361c174c1d93a44500d498ff44644d.tar
guix-patches-5bec698d47361c174c1d93a44500d498ff44644d.tar.gz
gnu: Add python-pytest-doctestplus.
* gnu/packages/python-check.scm (python-pytest-doctestplus): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 9d25753f70..38f6501fb0 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -152,6 +152,34 @@ data arrays produced during tests, in particular in cases where the arrays
are too large to conveniently hard-code them in the tests.")
(license license:bsd-3)))
+(define-public python-pytest-doctestplus
+ (package
+ (name "python-pytest-doctestplus")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-doctestplus" version))
+ (sha256
+ (base32 "1ai9kvd7xbq2jg2h8gmkb8lqzyrxvdh4zg3vxndg149iwd1hyi7d"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/astropy/pytest-doctestplus")
+ (synopsis "Pytest plugin with advanced doctest features")
+ (description
+ "This package contains a plugin for the Pytest framework that provides
+advanced doctest support and enables the testing of reStructuredText files.")
+ (license license:bsd-3)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")