summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 10:57:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commit3b89476b709c788e90ad6600a850ab06998cfc70 (patch)
tree1dd3214725b110f5e7736b9c71f4a616070612f4 /gnu/packages/python-check.scm
parent85bf6798e666d6c4e8d72b1d80efbb914094c0b2 (diff)
downloadguix-patches-3b89476b709c788e90ad6600a850ab06998cfc70.tar
guix-patches-3b89476b709c788e90ad6600a850ab06998cfc70.tar.gz
gnu: Add python-pytest-flake8.
* gnu/packages/python-check.scm (python-pytest-flake8): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 01aae06f61..95e10e6381 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -128,3 +128,26 @@ interactions, which will update them to correspond to the new API.")
"This package provides a pytest plugin that checks the long description
of the project to ensure it renders properly.")
(license license:expat)))
+
+(define-public python-pytest-flake8
+ (package
+ (name "python-pytest-flake8")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flake8" version))
+ (sha256
+ (base32
+ "1h30gd21fjsafqxwclf25sdh89vrdz7rsh4lzw11aiw7ww9mq8jd"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/tholo/pytest-flake8")
+ (synopsis "Pytest plugin to check FLAKE8 requirements")
+ (description
+ "This package provides a pytest plugin for efficiently checking PEP8
+compliance.")
+ (license license:bsd-3)))