summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 10:57:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commit85bf6798e666d6c4e8d72b1d80efbb914094c0b2 (patch)
treee197abb8261edbdaa0ac76a8b78ef7a0189f8369 /gnu/packages/python-check.scm
parent15b6561769cf9ed59b2cb31e664d4e0f25f97c92 (diff)
downloadguix-patches-85bf6798e666d6c4e8d72b1d80efbb914094c0b2.tar
guix-patches-85bf6798e666d6c4e8d72b1d80efbb914094c0b2.tar.gz
gnu: Add python-pytest-checkdocs.
* gnu/packages/python-check.scm (python-pytest-checkdocs): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 58a1022bc2..01aae06f61 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -105,3 +105,26 @@ is delete your existing cassette files, and run your tests again. VCR.py will
detect the absence of a cassette file and once again record all HTTP
interactions, which will update them to correspond to the new API.")
(license license:expat)))
+
+(define-public python-pytest-checkdocs
+ (package
+ (name "python-pytest-checkdocs")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-checkdocs" version))
+ (sha256
+ (base32
+ "07c27cdjcw6jph5kbgpxchrvwlps4ggwb2j6m7y64imnik0asrq8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-importlib-metadata" ,python-importlib-metadata)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/jaraco/pytest-checkdocs")
+ (synopsis "Check the README when running tests")
+ (description
+ "This package provides a pytest plugin that checks the long description
+of the project to ensure it renders properly.")
+ (license license:expat)))