summaryrefslogtreecommitdiff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 09:21:50 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:58:15 +0100
commitde488b3a5fff4535471f6706da03e1b74e6a37fd (patch)
tree16c3142f7f7b3e487d7e30eca9eff8230bb91c85 /gnu/packages/purescript.scm
parent5c826341a3a42030b8fccaa2c220b44a3e11983b (diff)
downloadguix-patches-de488b3a5fff4535471f6706da03e1b74e6a37fd.tar
guix-patches-de488b3a5fff4535471f6706da03e1b74e6a37fd.tar.gz
gnu: Add purescript.
* gnu/packages/purescript.scm (purescript): New variable. * gnu/packages/patches/purescript-relax-dependencies.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index 244fe0ed7d..13cd773839 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages purescript)
+ #:use-module (gnu packages)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
@@ -42,3 +43,91 @@
(sha256
(base32
"138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))))
+
+(define-public purescript
+ (package
+ (name "purescript")
+ (version "0.13.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/purescript/purescript-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1xss3wpv6wb38gsh9r635s09cxzmiz81hhssdxzdba2pw6ifzx8j"))
+ (patches (search-patches "purescript-relax-dependencies.patch"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-glob" ,ghc-glob)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-aeson-better-errors" ,ghc-aeson-better-errors)
+ ("ghc-aeson-pretty" ,ghc-aeson-pretty)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-bower-json" ,ghc-bower-json)
+ ("ghc-boxes" ,ghc-boxes)
+ ("ghc-cheapskate" ,ghc-cheapskate)
+ ("ghc-clock" ,ghc-clock)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-data-ordlist" ,ghc-data-ordlist)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-edit-distance" ,ghc-edit-distance)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-fsnotify" ,ghc-fsnotify)
+ ("ghc-happy" ,ghc-happy)
+ ("ghc-language-javascript" ,ghc-language-javascript)
+ ("ghc-lifted-async" ,ghc-lifted-async)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-memory" ,ghc-memory)
+ ("ghc-microlens-platform" ,ghc-microlens-platform)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-monad-logger" ,ghc-monad-logger)
+ ("ghc-network" ,ghc-network)
+ ("ghc-parallel" ,ghc-parallel)
+ ("ghc-pattern-arrows" ,ghc-pattern-arrows)
+ ("ghc-protolude" ,ghc-protolude)
+ ("ghc-regex-tdfa" ,ghc-regex-tdfa)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-semialign" ,ghc-semialign)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-sourcemap" ,ghc-sourcemap)
+ ("ghc-split" ,ghc-split)
+ ("ghc-stringsearch" ,ghc-stringsearch)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-these" ,ghc-these)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-network" ,ghc-network)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-wai-websockets" ,ghc-wai-websockets)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-websockets" ,ghc-websockets)))
+ (native-inputs
+ `(("ghc-happy" ,ghc-happy-1.19.9) ; build fails with 1.19.12
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-hspec" ,ghc-tasty-hspec)))
+ (arguments
+ `(;; Tests require npm
+ #:tests? #f
+ #:configure-flags '("--flags=release")))
+ (home-page "https://www.purescript.org/")
+ (synopsis "Haskell inspired programming language compiling to JavaScript")
+ (description
+ "Purescript is a small strongly, statically typed programming language with
+expressive types, inspired by Haskell and compiling to JavaScript.")
+ (license license:bsd-3)))