summaryrefslogtreecommitdiff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 08:52:48 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:26 +0100
commit5c826341a3a42030b8fccaa2c220b44a3e11983b (patch)
tree4cab49e429b1bb5efccc890b3583687270a7c173 /gnu/packages/purescript.scm
parent3cf7219cac454b6c01d86bd3dc30fad4d7e626db (diff)
downloadguix-patches-5c826341a3a42030b8fccaa2c220b44a3e11983b.tar
guix-patches-5c826341a3a42030b8fccaa2c220b44a3e11983b.tar.gz
gnu: Add ghc-happy@1.19.9
* gnu/packages/purescript.scm (ghc-happy-1.19.9): New file, New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add purescript.scm. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
new file mode 100644
index 0000000000..244fe0ed7d
--- /dev/null
+++ b/gnu/packages/purescript.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages purescript)
+ #:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages haskell-check)
+ #:use-module (gnu packages haskell-crypto)
+ #:use-module (gnu packages haskell-web)
+ #:use-module ((gnu packages python) #:select (python))
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system haskell)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define ghc-happy-1.19.9
+ (package
+ (inherit ghc-happy)
+ (version "1.19.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/happy/happy-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))))