summaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 09:11:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:50 +0200
commitde032eed5c124021e510ba032a44a3bdd1a51327 (patch)
tree8f93aacf75615975e991574da3b019e7afe8554d /gnu/packages/perl6.scm
parent489f4933840297b2a0a13fab537632b59ce8bfc4 (diff)
downloadguix-patches-de032eed5c124021e510ba032a44a3bdd1a51327.tar
guix-patches-de032eed5c124021e510ba032a44a3bdd1a51327.tar.gz
gnu: Add perl6-test-meta.
* gnu/packages/perl6.scm (perl6-test-meta): New variable.
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 403727c3f6..c1c1247540 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -452,6 +452,30 @@ TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+(define-public perl6-test-meta
+ (package
+ (name "perl6-test-meta")
+ (version "0.0.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/Test-META")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mzrglb7lbiy5h9dlc7dyhvv9gppxmdmpmrv6nzbd695jzr38bri"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-meta6" ,perl6-meta6)
+ ("perl6-uri" ,perl6-uri)))
+ (home-page "https://github.com/jonathanstowe/Test-META")
+ (synopsis "Test a distributions META file")
+ (description "This provides a simple mechanism for module authors to have
+some confidence that they have a working distribution META description file.")
+ (license license:artistic2.0)))
+
(define-public perl6-uri
(package
(name "perl6-uri")