summaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 09:10:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:50 +0200
commit489f4933840297b2a0a13fab537632b59ce8bfc4 (patch)
tree9ef048b2c671e38ec88fa2532b3cb29667b03717 /gnu/packages/perl6.scm
parent505b979272e9a23f94a78b9bc9a7934eab941483 (diff)
downloadguix-patches-489f4933840297b2a0a13fab537632b59ce8bfc4.tar
guix-patches-489f4933840297b2a0a13fab537632b59ce8bfc4.tar.gz
gnu: Add perl6-license-spdx.
* gnu/packages/perl6.scm (perl6-license-spdx): New variable.
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index d41167d2bb..403727c3f6 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -363,6 +363,31 @@ It will of course also be needed in classes thar are going to use
create an object from a JSON representation of an object.")
(license license:expat))))
+(define-public perl6-license-spdx
+ (package
+ (name "perl6-license-spdx")
+ (version "3.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/License-SPDX")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dl263c3fbxk001gm5fisrzqz1dx182ipaa0x2qva2gxvl075xm8"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-json-class" ,perl6-json-class)))
+ (home-page "https://github.com/jonathanstowe/License-SPDX")
+ (synopsis "Abstraction over the SPDX License List")
+ (description "This provides an abstraction over the SPDX License List as
+provided in JSON format. Its primary raison d'ĂȘtre is to help the licence
+checking of @code{Test::META} and to allow for the warning about deprecated
+licences therein.")
+ (license license:artistic2.0)))
+
(define-public perl6-meta6
(package
(name "perl6-meta6")