summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:11:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:46 +0200
commitf810d69b6c8fd72c85a363f2a210e1878f3cb00a (patch)
tree6b347c0710147bb25a8cae01f1fa84fc0cb24ac9 /gnu/packages/perl.scm
parente8356966b7c77c5046e4603e33da456119a37f8c (diff)
downloadguix-patches-f810d69b6c8fd72c85a363f2a210e1878f3cb00a.tar
guix-patches-f810d69b6c8fd72c85a363f2a210e1878f3cb00a.tar.gz
gnu: Use ‘license:’ prefix in (gnu packages perl).
* gnu/packages/perl.scm: Import (guix licenses) with a #:prefix and adjust all callers.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm266
1 files changed, 133 insertions, 133 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fab366fa8d..42839f4409 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -45,7 +45,7 @@
(define-module (gnu packages perl)
#:use-module (srfi srfi-1)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
@@ -256,7 +256,7 @@ text manipulation and now used for a wide range of tasks including system
administration, web development, network programming, GUI development, and
more.")
(home-page "https://www.perl.org/")
- (license gpl1+))) ; or "Artistic"
+ (license license:gpl1+))) ; or "Artistic"
(define-public perl-algorithm-c3
(package
@@ -479,7 +479,7 @@ SYS$HASH_PASSWORD password hashing function from VMS (also known as
LGI$HPWD) and some associated VMS username and password handling
functions. The password hashing function is implemented in XS with a
pure Perl backup version for systems that cannot handle XS.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public perl-authen-passphrase
(package
@@ -522,7 +522,7 @@ many schemes in use to achieve this effect and the intent of this
class is to provide a consistent interface to them all. In addition
to the base class, this module also contains implementations of
several specific passphrase schemes.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-autovivification
(package
@@ -664,7 +664,7 @@ keywords: @code{@@Scalars, @@Arrays, @@Hashes, @@Filehandles, @@Symbols,
@@Functions, @@Barewords, @@TieIOMethods, @@UNIVERSALMethods and
@@ExporterSymbols}.")
;; GPLv2 only
- (license gpl2)))
+ (license license:gpl2)))
(define-public perl-benchmark-timer
(package
@@ -690,7 +690,7 @@ trials. It is perfect for when you need more precise information about the
running time of portions of your code than the Benchmark module will give you,
but don't want to go all out and profile your code.")
(home-page "https://metacpan.org/release/Benchmark-Timer")
- (license gpl2)))
+ (license license:gpl2)))
(define-public perl-bit-vector
(package
@@ -715,7 +715,7 @@ matrices, all of arbitrary sizes. The package also includes an
object-oriented Perl module for accessing the C library from Perl, and
optionally features overloaded operators for maximum ease of use. The C
library can nevertheless be used stand-alone, without Perl.")
- (license (list (package-license perl) lgpl2.0+))))
+ (license (list (package-license perl) license:lgpl2.0+))))
(define-public perl-boolean
(package
@@ -775,7 +775,7 @@ Agency.")
(synopsis "Work with International Standard Book Numbers")
(description "This modules provides tools to deal with International
Standard Book Numbers, including ISBN-10 and ISBN-13.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-business-issn
(package
@@ -884,7 +884,7 @@ algorithm to keep the most used entries in the cache.")
sent to STDOUT or STDERR, regardless of whether it comes from Perl, from XS
code or from an external program. Optionally, output can be teed so that it
is captured while being passed through to the original file handles.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-canary-stability
(package
@@ -990,7 +990,7 @@ library assert.h.")
(synopsis "Convenience wrappers around Carp::Assert")
(description "Carp::Assert::More is a set of handy assertion functions for
Perl.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-carp-clan
(package
@@ -1031,7 +1031,7 @@ the Carp.pm module doesn't help.")
(synopsis "Read the CDDB entry for an audio CD in your drive")
(description "This module can retrieve information from the CDDB.")
;; Either GPLv2 or the "Artistic" license.
- (license (list gpl2 artistic2.0))))
+ (license (list license:gpl2 license:artistic2.0))))
(define-public circos
(package
@@ -1126,7 +1126,7 @@ the Carp.pm module doesn't help.")
(description
"Circos is a program for the generation of publication-quality, circularly
composited renditions of genomic data and related annotations.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public perl-class-accessor
(package
@@ -1421,7 +1421,7 @@ names, not Class::Name. For that, this module provides \"load_class
(synopsis "XS implementation of parts of Class::Load")
(description "This module provides an XS implementation for portions of
Class::Load.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-class-methodmaker
(package
@@ -1493,7 +1493,7 @@ with a hook to easily call that original method.")
module dynamically generates anonymous classes with specified
inheritance. This is useful where an incomplete class requires use of
a mixin in order to become instantiable.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-class-singleton
(package
@@ -1532,7 +1532,7 @@ little other than manage the instantiation of a single object.")
(synopsis "Minimalist class construction")
(description "This module offers a minimalist class construction kit. It
uses no non-core modules for any recent Perl.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-class-unload
(package
@@ -1623,7 +1623,7 @@ objects.")
(description "This @code{Clone::Choose} module checks several different
modules which provide a @code{clone()} function and selects an appropriate
one.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-clone-pp
(package
@@ -1692,7 +1692,7 @@ library. It support scalar, array, and hash data structures just like its C/C++
counterpart. It reduces the effort required to implement a configuration file
parser in your Perl programme and allows sharing configuration files between
languages.")
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public perl-config-grammar
(package
@@ -1827,7 +1827,7 @@ options.")
(description
"This module handles parsing, modifying and creating configuration files
of the style used by the Git version control system.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-config-ini
(package
@@ -1901,7 +1901,7 @@ the caller.")
mail, as short-lined, 7-bit, semi-compressed data streams. Ths module
provides a means of converting those data streams back into into binary
data.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-cpan-changes
(package
@@ -1922,7 +1922,7 @@ data.")
(description
"@code{CPAN::Changes} helps users programmatically read and write
@file{Changes} files that conform to a common specification.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-cpan-distnameinfo
(package
@@ -1944,7 +1944,7 @@ data.")
(description
"@code{CPAN::DistnameInfo} uses heuristics to extract the distribution
name and version from filenames.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-cpan-meta-check
(package
@@ -2010,7 +2010,7 @@ the cryptographic Cipher Block Chaining (CBC) mode. In combination
with a block cipher such as @code{Crypt::Rijndael} you can encrypt and
decrypt messages of arbitrarily long length. The encrypted messages
are compatible with the encryption format used by SSLeay.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-crypt-des
(package
@@ -2034,7 +2034,7 @@ are compatible with the encryption format used by SSLeay.")
the DES cryptography algorithm. The module implements the
@code{Crypt::CBC} interface which has blocksize, keysize, encrypt and
decrypt functions.")
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public perl-crypt-eksblowfish
(package
@@ -2068,7 +2068,7 @@ Cost and salt parameters together define a cipher family. Within each
family, the key determines the encryption function. This distribution
also includes an implementation of @code{bcrypt}, the Unix crypt()
password hashing algorithm based on Eksblowfish.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-crypt-mysql
(package
@@ -2095,7 +2095,7 @@ password hashing algorithm based on Eksblowfish.")
function. The module does not depend on an interface to the MySQL
database server. This enables the comparison of encrypted passwords
without the need for a real MySQL environment.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-crypt-passwdmd5
(package
@@ -2119,7 +2119,7 @@ without the need for a real MySQL environment.")
crypt()-compatible interfaces to the MD5-based crypt() function found
in various *nixes. It is based on the implementation found on FreeBSD
2.2.[56]-RELEASE.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-crypt-randpasswd
(package
@@ -2173,7 +2173,7 @@ supported encryption modes are:
@item @code{MODE_ECB}---Electronic cookbook mode
@item @code{MODE_OFB}---Output feedback
@end itemize")
- (license gpl3)))
+ (license license:gpl3)))
(define-public perl-crypt-rc4
(package
@@ -2216,7 +2216,7 @@ Unix @code{crypt} function. For those who need to construct
non-standard variants of @code{crypt}, the various building blocks
used in @code{crypt} are also supplied separately.")
;; Files in the 'fcrypt' directory are covered by a BSD licence.
- (license (list perl-license bsd-3))))
+ (license (list license:perl-license license:bsd-3))))
(define-public perl-cwd-guard
(package
@@ -2277,7 +2277,7 @@ It returns to the previous working directory when the object is destroyed.")
(description "Chaolin Zhang's Perl Library (czplib) contains assorted
functions and data structures for processing and analysing genomic and
bioinformatics data.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public perl-data
(package
@@ -2368,7 +2368,7 @@ on the Internet, and cryptographic fake entropy. The
Data::Entropy::Algorithms module contains a collection of fundamental
algorithms that use entropy. There are random number generators and
functions to shuffle arrays.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-integer
(package
@@ -2395,7 +2395,7 @@ data type. A native integer is one of the types of datum that can
appear in the numeric part of a Perl scalar. This module supplies
constants describing the native integer type. Both signed and
unsigned representations are handled.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-uniqid
(package
@@ -2456,7 +2456,7 @@ code that, when \"eval\"ed, produces a deep copy of the original arguments.")
@code{Data::Dumper} writes out their contents in Perl syntax. The references
can also be objects. The content of each variable is output in a single Perl
statement. It handles self-referential structures correctly.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-dumper-concise
(package
@@ -2503,7 +2503,7 @@ types of datum that can appear in the numeric part of a Perl scalar.
This module supplies constants describing the native floating point
type, classification functions and functions to manipulate floating
point values at a low level.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-optlist
(package
@@ -2594,7 +2594,7 @@ The maths behind this is unfortunately fiddly, hence this module.")
@item @code{Data::Perl::Bool}
@item @code{Data::Perl::Code}
@end itemize")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-printer
(package
@@ -2692,7 +2692,7 @@ of data out of your DATA section.")
(description
"Data::Section::Simple is a simple module to extract data from __DATA__
section of the file.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-data-stag
(package
@@ -2845,7 +2845,7 @@ applicable).")
(synopsis "XS wrapper for Date::Calc")
(description "Date::Calc::XS is an XS wrapper and C library plug-in for
Date::Calc.")
- (license (list (package-license perl) lgpl2.0+))))
+ (license (list (package-license perl) license:lgpl2.0+))))
(define-public perl-date-manip
(package
@@ -2891,7 +2891,7 @@ module may be used to create simple date objects. It handles validation,
interval arithmetic, and day-of-week calculation. It does not deal with
hours, minutes, seconds, and time zones.")
;; Can be used with either license.
- (license (list (package-license perl) gpl2+))))
+ (license (list (package-license perl) license:gpl2+))))
(define-public perl-datetime
(package
@@ -2921,7 +2921,7 @@ hours, minutes, seconds, and time zones.")
(description "DateTime is a class for the representation of date/time
combinations. It represents the Gregorian calendar, extended backwards in
time before its creation (in 1582).")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-datetime-calendar-julian
(package
@@ -3043,7 +3043,7 @@ or \"every day\". You can also create more complicated recurrences, such as
string formats of dates and times are simple and just require a basic regular
expression to extract the relevant information. Builder provides a simple way
to do this without writing reams of structural code.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-datetime-format-flexible
(package
@@ -3127,7 +3127,7 @@ order to create the appropriate objects.")
(synopsis "Parse ISO8601 date and time formats")
(description "@code{DateTime::Format::ISO8601} is a DateTime
extension that parses almost all ISO8601 date and time formats.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-datetime-format-natural
(package
@@ -3187,7 +3187,7 @@ parsing logic.")
function that is the reverse of `strftime(3)`, for `DateTime`. While
`strftime` takes a `DateTime` and a pattern and returns a string, `strptime`
takes a string and a pattern and returns the `DateTime` object associated.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-datetime-locale
(package
@@ -3373,7 +3373,7 @@ annotation to a Perl subroutine, resulting in resolvable calls to that
subroutine being mutated at compile time by arbitrary C code. This
module makes @code{cv_set_call_checker} and several supporting
functions available.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-devel-caller
(package
@@ -3437,7 +3437,7 @@ particular command is available.")
C library and its headers are available. You can also check for the presence of
particular functions in a library, or even that those functions return
particular results.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-devel-checkcompiler
(package
@@ -3482,7 +3482,7 @@ you can tell it to compile a C source file with optional linker flags.")
"@code{Devel::Cycle} This is a tool for finding circular references in
objects and other types of references. Because of Perl's reference-count
based memory management, circular references will cause memory leaks.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-devel-globaldestruction
(package
@@ -3545,7 +3545,7 @@ files/modules are installed or not).")
(description
"This module provides a basic way to discover if a piece of perl code is
allocating perl data and not releasing them again.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-devel-lexalias
(package
@@ -3639,7 +3639,7 @@ arbitrary parameters.")
Devel::StackTrace and Devel::StackTrace::Frame. These objects encapsulate the
information that can be retrieved via Perl's caller() function, as well as
providing a simple interface to this data.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-devel-stacktrace-ashtml
(package
@@ -3702,7 +3702,7 @@ each stack frame.")
(description "The @code{Digest::CRC} module calculates CRC sums of
all sorts. It contains wrapper functions with the correct parameters
for CRC-CCITT, CRC-16 and CRC-32.")
- (license public-domain)))
+ (license license:public-domain)))
(define-public perl-digest-hmac
(package
@@ -3744,7 +3744,7 @@ RSA Data Security Inc.@: MD4 Message Digest algorithm from within Perl
programs. The algorithm takes as input a message of arbitrary length
and produces as output a 128-bit \"fingerprint\" or \"message digest\"
of the input. MD4 is described in RFC 1320.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-digest-md5
(package
@@ -3840,7 +3840,7 @@ modules separately and deal with them after the module is done installing.")
dynamic loading as used by Perl. Some details of dynamic loading are
very platform-dependent, so correct use of these functions requires
the programmer to be mindfulof the space of platform variations.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-encode-detect
(package
@@ -3861,7 +3861,7 @@ the programmer to be mindfulof the space of platform variations.")
(synopsis "Detect the encoding of data")
(description "This package provides a class @code{Encode::Detect} to detect
the encoding of data.")
- (license mpl1.1)))
+ (license license:mpl1.1)))
(define-public perl-encode-eucjpascii
(package
@@ -3925,7 +3925,7 @@ also known as JIS 2000.")
part of Perl by default, including \"BIG5-1984\", \"BIG5-2003\", \"BIG5PLUS\",
\"BIG5EXT\", \"CCCII\", \"EUC-TW\", \"CNS11643-*\", \"GB18030\", and
\"UNISYS\".")
- (license expat)))
+ (license license:expat)))
(define-public perl-env-path
(package
@@ -4243,7 +4243,7 @@ handle Perl/XS typemap files, and their submodules.")
@command{pkg-config} utility, intended for use in the @file{Makefile.PL}
of perl extensions which bind libraries that @command{pkg-config} knows.
It is really just boilerplate code that you would have written yourself.")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public perl-extutils-typemaps-default
(package
@@ -4324,7 +4324,7 @@ interface XS for C++; it is a thin layer over plain XS.")
(synopsis "Watch for changes to files")
(description "This module provides a class to monitor a directory for
changes made to any file.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-file-configdir
(package
@@ -4512,7 +4512,7 @@ working directory. When the object is destroyed, the destructor calls
@code{chdir} to revert to the original working directory. By storing the
object in a lexical variable with a limited scope, this happens automatically
at the end of the scope.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-file-list
(package
@@ -4566,7 +4566,7 @@ It is intended for processing log and other similar text files which typically
have their newest entries appended to them. By default files are assumed to
be plain text and have a line ending appropriate to the OS. But you can set
the input record separator string on a per file basis.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-file-remove
(package
@@ -4803,7 +4803,7 @@ notifications of changes to a given file system path. It uses inotify2 on
Linux, fsevents on OS X, @code{kqueue} on FreeBSD, and
@code{FindFirstChangeNotification} on Windows if they're installed, and falls
back to a full directory scan if none of these are available.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-getopt-long
(package
@@ -4831,7 +4831,7 @@ single letters, and are introduced with a double dash \"--\". Support for
bundling of command line options, as was the case with the more traditional
single-letter approach, is provided but not enabled by default.")
;; Can be used with either license.
- (license (list (package-license perl) gpl2+))))
+ (license (list (package-license perl) license:gpl2+))))
(define-public perl-getopt-long-descriptive
(package
@@ -5023,7 +5023,7 @@ both) around an existing subroutine. Unlike other modules that
provide this capacity (e.g., Hook::PreAndPost and Hook::WrapSub),
Hook::LexWrap implements wrappers in such a way that the standard
caller function works correctly within the wrapped subroutine.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-importer
(package
@@ -5091,7 +5091,7 @@ compilation. Import::Into provides global methods to make this painless.")
(description "The inc::latest module helps bootstrap configure-time
dependencies for CPAN distributions. These dependencies get bundled into the
inc directory within a distribution and are used by Makefile.PL or Build.PL.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-indirect
(package
@@ -5192,7 +5192,7 @@ It also goes a bit into Perl C internals.")
a single nifty object oriented interface to greatly simplify your everyday
Perl IO idioms. It exports a single function called io, which returns a new
@code{IO::All} object. And that object can do it all!")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-io-captureoutput
(package
@@ -5400,7 +5400,7 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
(home-page "https://metacpan.org/release/IPC-Run3")
;; "You may use this module under the terms of the BSD, Artistic, or GPL
;; licenses, any version."
- (license (list bsd-3 gpl3+))))
+ (license (list license:bsd-3 license:gpl3+))))
(define-public perl-ipc-sharelite
(package
@@ -5591,7 +5591,7 @@ versa.")
(description
"This module provides lexicon-handling modules to read from other
localization formats, such as Gettext, Msgcat, and so on.")
- (license x11)))
+ (license license:x11)))
(define-public perl-log-any
(package
@@ -5747,7 +5747,7 @@ one: logging, exceptions, and translations.")
(description "This package is an internationalization library for Perl
that aims to be compatible with the Uniforum message translations system as
implemented for example in GNU gettext.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public perl-lingua-en-sentence
(package
@@ -5769,7 +5769,7 @@ implemented for example in GNU gettext.")
"The Lingua::EN::Sentence module contains the function get_sentences,
which splits text into its constituent sentences, based on a regular
expression and a list of abbreviations (built in and given).")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-lingua-translit
(package
@@ -5896,7 +5896,7 @@ functionality on lists which is not going to go into List::Util.")
(description "@code{List::MoreUtils::XS} provides some trivial but
commonly needed functionality on lists which is not going to go into
@code{List::Util}.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-list-someutils
(package
@@ -5973,7 +5973,7 @@ Build a Mail::Internet object, and then send it out using Mail::Mailer.
@item Mail::Util
\"Smart functions\" you should not depend on.
@end table")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-mail-sendmail
(package
@@ -5996,7 +5996,7 @@ Build a Mail::Internet object, and then send it out using Mail::Mailer.
(description "Mail::Sendmail is a pure perl module that provides a
simple means to send email from a perl script. The module only
requires Perl5 and a network connection.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-math-bezier
(package
@@ -6016,7 +6016,7 @@ requires Perl5 and a network connection.")
(description "This module implements the algorithm for the solution of Bezier
curves as presented by Robert D Miller in Graphics Gems V, \"Quick and Simple
Bezier Curve Drawing\".")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-math-round
(package
@@ -6035,7 +6035,7 @@ Bezier Curve Drawing\".")
(synopsis "Perl extension for rounding numbers")
(description "@code{Math::Round} provides functions to round numbers,
both positive and negative, in various ways.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-math-vecstat
(package
@@ -6074,7 +6074,7 @@ operated on.")
(synopsis "Make functions faster by trading space for time")
(description "This package transparently speeds up functions by caching
return values, trading space for time.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-memoize-expirelru
(package
@@ -6143,7 +6143,7 @@ MIME messages on Internet.")
"MIME-tools is a collection of Perl5 MIME:: modules for parsing,
decoding, and generating single- or multipart (even nested multipart) MIME
messages.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-mime-types
(package
@@ -6367,7 +6367,7 @@ several underlying implementations for a module. This can be used to provide
XS and pure Perl implementations of a module, or it could be used to load an
implementation for a given OS or any other case of needing to provide multiple
implementations.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-module-install
(package
@@ -6435,7 +6435,7 @@ use in @code{Module::Inspector}.
It can load a @file{MANIFEST} file that comes in a Perl distribution tarball,
examine the contents, and perform some simple tasks. It can also load the
@file{MANIFEST.SKIP} file and check that.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-module-pluggable
(package
@@ -6770,7 +6770,7 @@ namespace::autoclean to operate without blowing away your overloads. After
using MooseX::MarkAsMethods your overloads will be recognized by Class::MOP as
being methods, and class extension as well as composition from roles with
overloads will \"just work\".")
- (license lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public perl-moosex-methodattributes
(package
@@ -6954,7 +6954,7 @@ where plain Moose::Roles would lose the overloading.")
changes the default naming policy for the loading class so that accessors are
separated into get and set methods. The get methods have the same name as the
accessor, while set methods are prefixed with \"_set_\".")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-moosex-strictconstructor
(package
@@ -6980,7 +6980,7 @@ accessor, while set methods are prefixed with \"_set_\".")
(description "Simply loading this module makes your constructors
\"strict\". If your constructor is called with an attribute init argument
that your class does not declare, then it calls Moose->throw_error().")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-moosex-traits-pluggable
(package
@@ -7154,7 +7154,7 @@ constraint with coercion to load the class.")
(synopsis
"Using Moo and MooX:: packages the most lazy way")
(description "Contains the MooX and MooX::Role packages.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-moox-cmd
(package
@@ -7279,7 +7279,7 @@ installing configuration files or for finding any piece of settings.")
"@code{MooX::HandlesVia} is an extension of Moo's @code{handles}
attribute functionality. It provides a means of proxying functionality from
an external class to the given attribute.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-moox-late
(package
@@ -7316,7 +7316,7 @@ an external class to the given attribute.")
Currently Hash, Array and Code are supported. This feature requires
MooX::HandlesVia.
@end enumerate")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-moox-options
(package
@@ -7396,7 +7396,7 @@ generate a command line tool.")
"Loading @code{MooX::StrictConstructor} makes your constructors \"strict\".
If your constructor is called with an attribute init argument that your class
does not declare, then it dies.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-moox-types-mooselike
(package
@@ -7498,7 +7498,7 @@ of data.")
(description "@code{Mozilla::CA} provides a copy of Mozilla's bundle of
Certificate Authority certificates in a form that can be consumed by modules
and libraries based on OpenSSL.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public perl-multidimensional
(package
@@ -7624,7 +7624,7 @@ power and flexibility of perl. The module does not implement the
functionality of a RIB (Routing Information Base) nor does it modify the
kernel routing table of the host system. However, such operations could be
implemented using the API provided by the module.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-net-dns-native
(package
@@ -7647,7 +7647,7 @@ designed to be used with event loops. Names are resolved by your system's
native @code{getaddrinfo(3)} implementation, called in a separate thread to
avoid blocking the entire application. Threading overhead is limited by using
system threads instead of Perl threads.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-net-idn-encode
(package
@@ -7674,7 +7674,7 @@ names today (letter-digit-hyphen, /[A-Z0-9-]/i).
Use this module if you just want to convert domain names (or email addresses),
using whatever IDNA standard is the best choice at the moment.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-net-statsd
(package
@@ -7739,7 +7739,7 @@ output formats may include thousands separators - characters inserted between
each group of three characters counting right to left from the decimal point.
The characters used for the decimal point and the thousands separator come from
the locale information or can be specified by the user.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-number-range
(package
@@ -7854,7 +7854,7 @@ instance, not by name.")
(synopsis "Manage deprecation warnings for your distribution")
(description "This module allows you to manage a set of deprecations for
one or more modules.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-package-stash
(package
@@ -7984,7 +7984,7 @@ for arguments of the types handled by the classification functions.
Enforcement of more complex types may be built using the
classification functions, or it may be more convenient to use a module
designed for the more complex job, such as @code{Params::Validate}")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-params-util
(package
@@ -8030,7 +8030,7 @@ checking parameters easier.")
(synopsis "Validate method/function parameters")
(description "The Params::Validate module allows you to validate method or
function call parameters to an arbitrary level of specificity.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-params-validationcompiler
(package
@@ -8061,7 +8061,7 @@ parameter checking subroutine. It can handle named or positional
parameters, and can return the parameters as key/value pairs or a list
of values. In addition to type checks, it also supports parameter
defaults, optional parameters, and extra \"slurpy\" parameters.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-par-dist
(package
@@ -8134,7 +8134,7 @@ directory specifications in a cross-platform manner.")
(synopsis "Tools for working with directory and file names")
(description "This package provides functions to work with directory and
file names.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-path-tiny
(package
@@ -8159,7 +8159,7 @@ file names.")
(synopsis "File path utility")
(description "This module provides a small, fast utility for working
with file paths.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-pdf-api2
(package
@@ -8183,7 +8183,7 @@ with file paths.")
(synopsis "Facilitates the creation and modification of PDF files")
(description "This Perl module facilitates the creation and modification
of PDF files.")
- (license lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public perl-perlio-utf8_strict
(package
@@ -8327,7 +8327,7 @@ applications.")
(synopsis "Parse, analyze and manipulate Perl (without Perl)")
(description "The PPI module parses, analyzes and manipulates Perl
code.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-probe-perl
(package
@@ -8416,7 +8416,7 @@ variables that should not be changed.")
@code{Ref::Util}, which provides several functions to help identify references
in a more convenient way than the usual approach of examining the return value
of @code{ref}.")
- (license x11)))
+ (license license:x11)))
(define-public perl-regexp-common
(package
@@ -8440,7 +8440,7 @@ offensive language, lists of any pattern, IPv4 addresses, URIs, and Zip
codes.")
(home-page "https://metacpan.org/release/Regexp-Common")
;; Quad-licensed: Perl Artistic, Perl Artistic 2.0, X11, and BSD.
- (license (list (package-license perl) x11 bsd-3))))
+ (license (list (package-license perl) license:x11 license:bsd-3))))
(define-public perl-regexp-util
(package
@@ -8547,7 +8547,7 @@ strings it is necessary to understand these implementation details.
This module provides functions to classify a string by encoding and to
encode a string in a desired way. The module is implemented in XS,
with a pure Perl backup version for systems that cannot handle XS.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-scope-guard
(package
@@ -8608,7 +8608,7 @@ collector.")
(synopsis "Manage sets of integers")
(description "@code{Set::IntSpan} manages sets of integers. It is
optimized for sets that have long runs of consecutive integers.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-set-object
(package
@@ -8629,7 +8629,7 @@ optimized for sets that have long runs of consecutive integers.")
(synopsis "Unordered collections of Perl Objects")
(description "Set::Object provides efficient sets, unordered collections
of Perl objects without duplicates for scalars and references.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-set-scalar
(package
@@ -8722,7 +8722,7 @@ magically make the Perl interpreter start checking a value's type on assignment
to a variable. In fact, there's no built-in way to apply a type to a variable at
all. Instead, you can explicitly check a value against a type, and optionally
coerce values to that type.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-spiffy
(package
@@ -8766,7 +8766,7 @@ other OO languages like Python, Ruby, Java and Perl 6.")
(synopsis "Collection of very basic statistics modules")
(description "This package provides basic statistics functions like
@code{median()}, @code{mean()}, @code{variance()} and @code{stddev()}.")
- (license lgpl2.0)))
+ (license license:lgpl2.0)))
(define-public perl-stream-buffered
(package
@@ -8895,7 +8895,7 @@ removing double-quotes, and truncating to fit within a desired length.")
"@code{String::Formatter} is a tool for building sprintf-like formatting
routines. It supports named or positional formatting, custom conversions,
fixed string interpolation, and simple width-matching.")
- (license gpl2)))
+ (license license:gpl2)))
(define-public perl-string-rewriteprefix
(package
@@ -9161,7 +9161,7 @@ the superclass---at least conditionally and temporarily. This module provides
nicer equivalents to the native Perl syntax for calling superclasses, along with
a universal @code{super} method to determine a class' own superclass, and better
support for run-time mix-ins and roles.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-svg
(package
@@ -9293,7 +9293,7 @@ of a system.")
"Sys::Syscall allows one to use epoll and sendfile system calls from
Perl. Support is mostly Linux-only for now, but other syscalls/OSes are
planned for the future.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-task-weaken
(package
@@ -9371,7 +9371,7 @@ documents: HTML, XML, POD, PostScript, LaTeX, and so on.")
(synopsis "Profiling for Template Toolkit")
(description "Template::Timer provides inline profiling of the template
processing in Perl code.")
- (license (list gpl3 artistic2.0))))
+ (license (list license:gpl3 license:artistic2.0))))
(define-public perl-template-tiny
(package
@@ -9397,7 +9397,7 @@ functionality from Template Toolkit in as few lines of code as possible.
It is intended for use in light-usage, low-memory, or low-cpu templating
situations, where you may need to upgrade to the full feature set in the
future, or if you want the retain the familiarity of TT-style templates.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-term-encoding
(package
@@ -9633,7 +9633,7 @@ into tables.")
(synopsis "Align text")
(description "Text::Aligner exports a single function, align(), which is
used to justify strings to various alignment styles.")
- (license x11)))
+ (license license:x11)))
(define-public perl-text-balanced
(package
@@ -9741,7 +9741,7 @@ generally slower on larger files.")
(description "This package provides functions to format text in various
ways like centering, paragraphing, and converting tabs to spaces and spaces
to tabs.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-text-glob
(package
@@ -9786,7 +9786,7 @@ you want to do full file globbing use the File::Glob module instead.")
(description
"Text::Haml implements Haml
@url{http://haml.info/docs/yardoc/file.REFERENCE.html} specification.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-text-neattemplate
(package
@@ -9832,7 +9832,7 @@ yet need more features than simple variable substitution.")
(description "Text::Patch combines source text with given
diff (difference) data. Diff data is produced by Text::Diff module or
by the standard @code{diff} utility.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public perl-text-roman
(package
@@ -9870,7 +9870,7 @@ algorism to indicate multiplication by 1000.")
(home-page "https://metacpan.org/release/Text-SimpleTable")
(synopsis "Simple ASCII tables")
(description "Text::SimpleTable draws simple ASCII tables.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-text-table
(package
@@ -9892,7 +9892,7 @@ algorism to indicate multiplication by 1000.")
(home-page "https://metacpan.org/release/Text-Table")
(synopsis "Organize Data in Tables")
(description "Text::Table renders plaintext tables.")
- (license x11)))
+ (license license:x11)))
(define-public perl-text-template
(package
@@ -9921,7 +9921,7 @@ algorism to indicate multiplication by 1000.")
filling in templates generally. A template is a piece of text that has little
Perl programs embedded in it here and there. When you fill in a template, you
evaluate the little programs and replace them with their values.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-text-unidecode
(package
@@ -9960,7 +9960,7 @@ system.")
(home-page "https://metacpan.org/release/threads")
(synopsis "Perl interpreter-based threads")
(description "This module exposes interpreter threads to the Perl level.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-throwable
(package
@@ -10005,7 +10005,7 @@ as exceptions to standard program flow.")
reformats Perl scripts to make them easier to read. The formatting can be
controlled with command line parameters. The default parameter settings
approximately follow the suggestions in the Perl Style Guide.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public perl-tie-cycle
(package
@@ -10069,7 +10069,7 @@ operations can also be performed on the IxHash.")
(description
"This modules provides a file handle that hides the beginning of a file,
by modifying the @code{seek()} and @code{tell()} calls.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-tie-simple
(package
@@ -10094,7 +10094,7 @@ myself wanting to use from time-to-time.
The Tie::Simple package is actually a front-end to other classes which really
do all the work once tied, but this package does the dwimming to automatically
figure out what you're trying to do.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-tie-toobject
(package
@@ -10180,7 +10180,7 @@ duration strings like \"2 minutes\" and \"3 seconds\" to seconds.")
(description "This package implements @code{usleep}, @code{ualarm}, and
@code{gettimeofday} for Perl, as well as wrappers to implement @code{time},
@code{sleep}, and @code{alarm} that know about non-integral seconds.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-time-local
(package
@@ -10223,7 +10223,7 @@ the system epoch.")
functions with implementations that return objects. It does so in a
backwards-compatible manner, so that using these functions as documented will
still work as expected.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-timedate
(package
@@ -10330,7 +10330,7 @@ Tree::Simple::Visitor::* objects.")
(description "This module provides bare bones try/catch/finally statements
that are designed to minimize common mistakes with eval blocks, and nothing
else.")
- (license x11)))
+ (license license:x11)))
(define-public perl-type-tie
(package
@@ -10410,7 +10410,7 @@ be used with Moose, Mouse and Moo (or none of the above).")
provide faster, C-based implementations of some type constraints. This
package has only core dependencies, and does not depend on @code{Type::Tiny},
so other data validation frameworks might also consider using it.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-types-path-tiny
(package
@@ -10435,7 +10435,7 @@ so other data validation frameworks might also consider using it.")
etc. It handles two important types of coercion: coercing objects with
overloaded stringification, and coercing to absolute paths. It also can check
to ensure that files or directories exist.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-types-serialiser
(package
@@ -10515,7 +10515,7 @@ common serialisation formats such as JSON or CBOR.")
Unicode data.")
;; The file Unicode/Collate/allkeys.txt is released under the Expat
;; license.
- (license (list (package-license perl) expat))))
+ (license (list (package-license perl) license:expat))))
(define-public perl-unicode-linebreak
(package
@@ -10674,7 +10674,7 @@ that there is exactly one document element, and that there are not duplicate
attribute names.")
;; Redistribution and use in source and compiled forms, with or without
;; modification, are permitted under any circumstances. No warranty.
- (license public-domain)))
+ (license license:public-domain)))
(define-public perl-xs-object-magic
(package
@@ -10739,7 +10739,7 @@ on the YAML 1.0 specification.")
(description
"@code{YAML::XS} is a Perl XS binding to libyaml which offers Perl the
best YAML support to date.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-yaml-tiny
(package
@@ -10789,7 +10789,7 @@ and memory overhead.")
(description
"@code{Parse::RecDescent} can incrementally generate top-down
recursive-descent text parsers from simple yacc-like grammar specifications.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-parse-yapp
(package
@@ -11005,7 +11005,7 @@ such that being individual extensions would be wasteful.")
"Object-oriented File::Find replacement in Perl")
(description "File::Find::Object is an object-oriented
File::Find replacement in Perl.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-file-find-object-rule
(package
@@ -11066,7 +11066,7 @@ object's options and steps, and then adds the new step, returning the new
object. In this manner, an object can be grown, step by step, by chaining
method calls. Furthermore, a partial sequence can be created and held, and
used as the head of many different sequences.")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-font-ttf
(package
@@ -11090,7 +11090,7 @@ font hacking. It supports reading, processing and writing of the following
tables: GDEF, GPOS, GSUB, LTSH, OS/2, PCLT, bsln, cmap, cvt, fdsc, feat,
fpgm, glyf, hdmx, head, hhea, hmtx, kern, loca, maxp, mort, name, post, prep,
prop, vhea, vmtx and the reading and writing of all other table types.")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-libtime-parsedate
(package
@@ -11131,7 +11131,7 @@ prop, vhea, vmtx and the reading and writing of all other table types.")
;; "License hereby granted for anyone to use, modify or redistribute this
;; module at their own risk. Please feed useful changes back to
;; cpan@dave.sharnoff.org."
- (license (non-copyleft "http://metadata.ftp-master.debian.org/\
+ (license (license:non-copyleft "http://metadata.ftp-master.debian.org/\
changelogs/main/libt/libtime-parsedate-perl/\
libtime-parsedate-perl_2015.103-2_copyright"))))
@@ -11160,7 +11160,7 @@ time periods allows you to test for conditions like \"Monday to Friday, 9am
till 5pm\" and \"on the second Tuesday of the month\" and \"between 4pm and
4:15pm\" and \"in the first half of each minute\" and \"in January of
1998\".")
- (license perl-license)))
+ (license license:perl-license)))
(define-public perl-path-iterator-rule
(package
@@ -11209,7 +11209,7 @@ A summary of features for comparison to other file finding modules:
As a convenience, the PIR module is an empty subclass of this one that is less
arduous to type for one-liners.")
- (license asl2.0)))
+ (license license:asl2.0)))
(define-public perl-pod-constants
(package
@@ -11235,7 +11235,7 @@ Pod::Constants uses Pod::Parser to do the parsing of the source file. It has
to open the source file it is called from, and does so directly either by
lookup in %INC or by assuming it is $0 if the caller is @code{main}
(or it can't find %INC{caller()}).")
- (license artistic2.0)))
+ (license license:artistic2.0)))
(define-public perl-regexp-pattern
(package
@@ -11281,4 +11281,4 @@ regexp patterns in modules.")
(synopsis "Parse Lisp S-Expressions into Perl data structures")
(description "Data::SExpression parses Lisp S-Expressions into Perl data
structures.")
- (license perl-license)))
+ (license license:perl-license)))