summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 11:47:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:45 +0200
commite8356966b7c77c5046e4603e33da456119a37f8c (patch)
tree6730d8444d2098b4ac473d5662f0f6d865dedb10 /gnu/packages/perl.scm
parent10ed3525a42623178c444628187914998c034a05 (diff)
downloadguix-patches-e8356966b7c77c5046e4603e33da456119a37f8c.tar
guix-patches-e8356966b7c77c5046e4603e33da456119a37f8c.tar.gz
gnu: Add perl-text-patch.
* gnu/packages/perl.scm (perl-text-patch): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 86c9f0eba6..fab366fa8d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9813,6 +9813,27 @@ template engine, for when you need speed rather than complex features,
yet need more features than simple variable substitution.")
(license (package-license perl))))
+(define-public perl-text-patch
+ (package
+ (name "perl-text-patch")
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CA/CADE/"
+ "Text-Patch-" version ".tar.gz"))
+ (sha256
+ (base32 "1k1xbhxwn9fymqqwnam9pm7hr2p5ikq6dk578qw18gkap9hqxwga"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-text-diff" ,perl-text-diff)))
+ (home-page "https://metacpan.org/release/Text-Patch")
+ (synopsis "Patches text with given patch")
+ (description "Text::Patch combines source text with given
+diff (difference) data. Diff data is produced by Text::Diff module or
+by the standard @code{diff} utility.")
+ (license gpl2+)))
+
(define-public perl-text-roman
(package
(name "perl-text-roman")