summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-21 21:51:29 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:29:37 +0200
commit930945015c76083efc0dd140d6bd2cbd3ecc44ad (patch)
tree69db29ecc480625683e097b836d12023a2fd8fda /gnu/packages/patches
parent8fd857f5da6a43c8c384079e50db57392b99ec45 (diff)
downloadguix-patches-930945015c76083efc0dd140d6bd2cbd3ecc44ad.tar
guix-patches-930945015c76083efc0dd140d6bd2cbd3ecc44ad.tar.gz
gnu: Add fastcap.
* gnu/packages/engineering.scm (fastcap): New variable. (broken-tarball-fetch): New function. Suggested by Ludovic Courtès <ludo@gnu.org>. * gnu/packages/patches/fastcap-mulGlobal.patch, gnu/packages/patches/fastcap-mulSetup.patch: New files. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fastcap-mulGlobal.patch13
-rw-r--r--gnu/packages/patches/fastcap-mulSetup.patch19
2 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/fastcap-mulGlobal.patch b/gnu/packages/patches/fastcap-mulGlobal.patch
new file mode 100644
index 0000000000..efb3b570db
--- /dev/null
+++ b/gnu/packages/patches/fastcap-mulGlobal.patch
@@ -0,0 +1,13 @@
+Don't use timing as there is a type conflict.
+
+--- nix-build-fastcap-2.0-18Sep92.drv-1/src/mulGlobal.h.orig 2015-07-21 15:58:49.199101566 +0200
++++ nix-build-fastcap-2.0-18Sep92.drv-1/src/mulGlobal.h 2015-07-21 16:18:39.456751313 +0200
+@@ -57,7 +57,7 @@
+ /* time variables/structs */
+ #ifndef _TIME_ /* if not on a Sun4 */
+ #ifndef NEWS /* if not on a NWS-38XX */
+-#include <time.h>
++//#include <time.h>
+ #endif
+ #endif
+
diff --git a/gnu/packages/patches/fastcap-mulSetup.patch b/gnu/packages/patches/fastcap-mulSetup.patch
new file mode 100644
index 0000000000..00eb7e96b5
--- /dev/null
+++ b/gnu/packages/patches/fastcap-mulSetup.patch
@@ -0,0 +1,19 @@
+Add forward declarations.
+
+--- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200
++++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200
+@@ -35,6 +35,14 @@
+
+ #include "mulGlobal.h"
+
++static getnbrs(ssystem*);
++static linkcubes(ssystem*);
++static setMaxq(ssystem*);
++static getAllInter(ssystem*);
++static set_vector_masks(ssystem*);
++static indexkid(ssystem*, cube*, int*, int*);
++static int placeq(int, ssystem*, charge*);
++
+ cube *cstack[1024]; /* Stack used in several routines. */
+
+ /*