summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fastcap-mulSetup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/fastcap-mulSetup.patch')
-rw-r--r--gnu/packages/patches/fastcap-mulSetup.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/fastcap-mulSetup.patch b/gnu/packages/patches/fastcap-mulSetup.patch
new file mode 100644
index 0000000000..00eb7e96b5
--- /dev/null
+++ b/gnu/packages/patches/fastcap-mulSetup.patch
@@ -0,0 +1,19 @@
+Add forward declarations.
+
+--- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200
++++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200
+@@ -35,6 +35,14 @@
+
+ #include "mulGlobal.h"
+
++static getnbrs(ssystem*);
++static linkcubes(ssystem*);
++static setMaxq(ssystem*);
++static getAllInter(ssystem*);
++static set_vector_masks(ssystem*);
++static indexkid(ssystem*, cube*, int*, int*);
++static int placeq(int, ssystem*, charge*);
++
+ cube *cstack[1024]; /* Stack used in several routines. */
+
+ /*