summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/owncloud-disable-updatecheck.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-18 19:30:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-18 21:50:08 +0200
commit6563d58c7e94bee8b9beeefa929ab2e982d86fa0 (patch)
treea739db58d6a9ac9e2f3e0373dea8d15d2bbdb91a /gnu/packages/patches/owncloud-disable-updatecheck.patch
parent42ca84be9260d6a1ce12847b89545882b112a2cd (diff)
downloadguix-patches-6563d58c7e94bee8b9beeefa929ab2e982d86fa0.tar
guix-patches-6563d58c7e94bee8b9beeefa929ab2e982d86fa0.tar.gz
gnu: owncloud-client: Don't check for updates.
* gnu/packages/sync.scm (owncloud-client)[source]: Add patch. * gnu/packages/patches/owncloud-disable-updatecheck.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/owncloud-disable-updatecheck.patch')
-rw-r--r--gnu/packages/patches/owncloud-disable-updatecheck.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/patches/owncloud-disable-updatecheck.patch b/gnu/packages/patches/owncloud-disable-updatecheck.patch
new file mode 100644
index 0000000000..69a984a104
--- /dev/null
+++ b/gnu/packages/patches/owncloud-disable-updatecheck.patch
@@ -0,0 +1,49 @@
+This patch is taken from Debian and modified slightly
+
+Description: Phoning-home version checks should be disabled in Debian packages
+Author: Sandro Knauß <bugs@ssandroknauss.de>
+Origin: debian
+Bug-debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721341
+Forwarded: not-needed
+Last-Update: 2014-02-17
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/libsync/configfile.cpp
++++ b/src/libsync/configfile.cpp
+@@ -417,11 +417,14 @@ bool ConfigFile::skipUpdateCheck( const
+ QString con( connection );
+ if( connection.isEmpty() ) con = defaultConnection();
+
+- QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
++ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
+ fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
+
+ QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
+- return value.toBool();
++ if ( !value.toBool() )
++ qDebug() << "Guix has disabled the UpdateCheck mechanism.";
++
++ return true;
+ }
+
+ void ConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
+--- a/src/gui/generalsettings.cpp
++++ b/src/gui/generalsettings.cpp
+@@ -124,6 +124,7 @@ void GeneralSettings::loadMiscSettings()
+
+ void GeneralSettings::slotUpdateInfo()
+ {
++ /* Guix doesn't want an autoupdater
+ // Note: the sparkle-updater is not an OCUpdater
+ OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
+ if (ConfigFile().skipUpdateCheck()) {
+@@ -140,6 +141,9 @@ void GeneralSettings::slotUpdateInfo()
+ // can't have those infos from sparkle currently
+ _ui->updatesGroupBox->setVisible(false);
+ }
++ */
++ //hide the update group box for Guix.
++ _ui->updatesGroupBox->setVisible(false);
+ }
+
+ void GeneralSettings::saveMiscSettings()