summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/owncloud-disable-updatecheck.patch49
-rw-r--r--gnu/packages/sync.scm2
3 files changed, 52 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 71ed39f34a..2fbafe1187 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -936,6 +936,7 @@ dist_patch_DATA = \
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
%D%/packages/patches/osip-CVE-2017-7853.patch \
%D%/packages/patches/ots-no-include-missing-file.patch \
+ %D%/packages/patches/owncloud-disable-updatecheck.patch \
%D%/packages/patches/p7zip-CVE-2016-9296.patch \
%D%/packages/patches/p7zip-remove-unused-code.patch \
%D%/packages/patches/patchelf-page-size.patch \
diff --git a/gnu/packages/patches/owncloud-disable-updatecheck.patch b/gnu/packages/patches/owncloud-disable-updatecheck.patch
new file mode 100644
index 0000000000..69a984a104
--- /dev/null
+++ b/gnu/packages/patches/owncloud-disable-updatecheck.patch
@@ -0,0 +1,49 @@
+This patch is taken from Debian and modified slightly
+
+Description: Phoning-home version checks should be disabled in Debian packages
+Author: Sandro Knauß <bugs@ssandroknauss.de>
+Origin: debian
+Bug-debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721341
+Forwarded: not-needed
+Last-Update: 2014-02-17
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/libsync/configfile.cpp
++++ b/src/libsync/configfile.cpp
+@@ -417,11 +417,14 @@ bool ConfigFile::skipUpdateCheck( const
+ QString con( connection );
+ if( connection.isEmpty() ) con = defaultConnection();
+
+- QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
++ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
+ fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
+
+ QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
+- return value.toBool();
++ if ( !value.toBool() )
++ qDebug() << "Guix has disabled the UpdateCheck mechanism.";
++
++ return true;
+ }
+
+ void ConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
+--- a/src/gui/generalsettings.cpp
++++ b/src/gui/generalsettings.cpp
+@@ -124,6 +124,7 @@ void GeneralSettings::loadMiscSettings()
+
+ void GeneralSettings::slotUpdateInfo()
+ {
++ /* Guix doesn't want an autoupdater
+ // Note: the sparkle-updater is not an OCUpdater
+ OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
+ if (ConfigFile().skipUpdateCheck()) {
+@@ -140,6 +141,9 @@ void GeneralSettings::slotUpdateInfo()
+ // can't have those infos from sparkle currently
+ _ui->updatesGroupBox->setVisible(false);
+ }
++ */
++ //hide the update group box for Guix.
++ _ui->updatesGroupBox->setVisible(false);
+ }
+
+ void GeneralSettings::saveMiscSettings()
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 66e9c4eddb..17972cd4ad 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -22,6 +22,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix download)
#:use-module (guix packages)
+ #:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
@@ -43,6 +44,7 @@
"owncloudclient-" version ".tar.xz"))
(sha256
(base32 "1r5ddln1wc9iyjizgqb104i0r6qhzsmm2wdnxfaif119cv0vphda"))
+ (patches (search-patches "owncloud-disable-updatecheck.patch"))
(modules '((guix build utils)))
(snippet
'(begin