summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-locales.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-11 11:19:29 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-11 11:19:29 +0100
commitaee6180c10ab0c63430b7589167bf9e5846e6919 (patch)
tree38563749fdb8de834b7332b24c4f0081191365c2 /gnu/packages/patches/glibc-locales.patch
parentfbe952c99f5ab8d6001984d4b74469e48178d4c7 (diff)
downloadguix-patches-aee6180c10ab0c63430b7589167bf9e5846e6919.tar
guix-patches-aee6180c10ab0c63430b7589167bf9e5846e6919.tar.gz
gnu: Add glibc-locales.
* gnu/packages/patches/glibc-locales.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc-locales): New variable.
Diffstat (limited to 'gnu/packages/patches/glibc-locales.patch')
-rw-r--r--gnu/packages/patches/glibc-locales.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-locales.patch b/gnu/packages/patches/glibc-locales.patch
new file mode 100644
index 0000000000..1d254e1c1d
--- /dev/null
+++ b/gnu/packages/patches/glibc-locales.patch
@@ -0,0 +1,31 @@
+This patch allows us to use glibc's build system to build locales
+in a package separate from glibc.
+
+ 1. Use 'localedef' from $PATH since we are not rebuilding it.
+ 2. Use '--no-archive' to avoid building the big locale archive, and
+ because the already-built 'localedef' would want to write it
+ to '/run/current-system/locale', which is not possible.
+ 3. Pass $(localedir)/$$locale to install files in the right place, and
+ because otherwise, 'localedef' fails with:
+ "cannot write output files to `(null)'".
+
+--- glibc-2.20/localedata/Makefile 2014-09-07 10:09:09.000000000 +0200
++++ glibc-2.20/localedata/Makefile 2015-02-11 10:23:55.560545568 +0100
+@@ -217,7 +217,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
+
+ # Sometimes the whole collection of locale files should be installed.
+ LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
+-$(rtld-prefix) $(common-objpfx)locale/localedef
++ localedef --no-archive
+ install-locales: $(INSTALL-SUPPORTED-LOCALES)
+
+ install-locales-dir:
+@@ -234,7 +234,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
+ input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
+ $(LOCALEDEF) --alias-file=../intl/locale.alias \
+ -i locales/$$input -c -f charmaps/$$charset \
+- $(addprefix --prefix=,$(install_root)) $$locale; \
++ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale; \
+ echo ' done'; \
+
+ tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP