summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-11 11:19:29 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-11 11:19:29 +0100
commitaee6180c10ab0c63430b7589167bf9e5846e6919 (patch)
tree38563749fdb8de834b7332b24c4f0081191365c2
parentfbe952c99f5ab8d6001984d4b74469e48178d4c7 (diff)
downloadguix-patches-aee6180c10ab0c63430b7589167bf9e5846e6919.tar
guix-patches-aee6180c10ab0c63430b7589167bf9e5846e6919.tar.gz
gnu: Add glibc-locales.
* gnu/packages/patches/glibc-locales.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc-locales): New variable.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/base.scm35
-rw-r--r--gnu/packages/patches/glibc-locales.patch31
3 files changed, 67 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index a46647e450..1a68b8bfa2 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -393,6 +393,7 @@ dist_patch_DATA = \
gnu/packages/patches/glibc-CVE-2014-7817.patch \
gnu/packages/patches/glibc-bootstrap-system.patch \
gnu/packages/patches/glibc-ldd-x86_64.patch \
+ gnu/packages/patches/glibc-locales.patch \
gnu/packages/patches/glibc-mips-dangling-vfork-ref.patch \
gnu/packages/patches/gmp-arm-asm-nothumb.patch \
gnu/packages/patches/gnunet-fix-scheduler.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index be33cb2caf..554e848369 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages pkg-config)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -520,6 +521,40 @@ with the Linux kernel.")
(license lgpl2.0+)
(home-page "http://www.gnu.org/software/libc/")))
+(define-public glibc-locales
+ (package
+ (inherit glibc)
+ (name "glibc-locales")
+ (source (origin (inherit (package-source glibc))
+ (patches (cons (search-patch "glibc-locales.patch")
+ (origin-patches (package-source glibc))))))
+ (synopsis "All the locales supported by the GNU C Library")
+ (description
+ "This package provides all the locales supported by the GNU C Library,
+more than 400 in total. To use them set the 'LOCPATH' environment variable to
+the 'share/locale' sub-directory of this package.")
+ (outputs '("out")) ;110+ MiB
+ (arguments
+ (let ((args `(#:tests? #f #:strip-binaries? #f
+ ,@(package-arguments glibc))))
+ (substitute-keyword-arguments args
+ ((#:phases phases)
+ `(alist-replace
+ 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Delete $out/bin, which contains 'bash'.
+ (delete-file-recursively (string-append out "/bin")))
+
+ (zero? (system* "make" "localedata/install-locales"
+ "-j" (number->string (parallel-job-count)))))
+ (alist-delete 'install ,phases)))
+ ((#:configure-flags flags)
+ `(append ,flags
+ (list (string-append "libc_cv_localedir="
+ (assoc-ref %outputs "out")
+ "/share/locale")))))))))
+
(define-public tzdata
(package
(name "tzdata")
diff --git a/gnu/packages/patches/glibc-locales.patch b/gnu/packages/patches/glibc-locales.patch
new file mode 100644
index 0000000000..1d254e1c1d
--- /dev/null
+++ b/gnu/packages/patches/glibc-locales.patch
@@ -0,0 +1,31 @@
+This patch allows us to use glibc's build system to build locales
+in a package separate from glibc.
+
+ 1. Use 'localedef' from $PATH since we are not rebuilding it.
+ 2. Use '--no-archive' to avoid building the big locale archive, and
+ because the already-built 'localedef' would want to write it
+ to '/run/current-system/locale', which is not possible.
+ 3. Pass $(localedir)/$$locale to install files in the right place, and
+ because otherwise, 'localedef' fails with:
+ "cannot write output files to `(null)'".
+
+--- glibc-2.20/localedata/Makefile 2014-09-07 10:09:09.000000000 +0200
++++ glibc-2.20/localedata/Makefile 2015-02-11 10:23:55.560545568 +0100
+@@ -217,7 +217,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
+
+ # Sometimes the whole collection of locale files should be installed.
+ LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
+-$(rtld-prefix) $(common-objpfx)locale/localedef
++ localedef --no-archive
+ install-locales: $(INSTALL-SUPPORTED-LOCALES)
+
+ install-locales-dir:
+@@ -234,7 +234,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
+ input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
+ $(LOCALEDEF) --alias-file=../intl/locale.alias \
+ -i locales/$$input -c -f charmaps/$$charset \
+- $(addprefix --prefix=,$(install_root)) $$locale; \
++ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale; \
+ echo ' done'; \
+
+ tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP