summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/flint-ldconfig.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-08-14 17:46:31 +0200
committerAndreas Enge <andreas@enge.fr>2015-08-14 18:14:33 +0200
commit6c591c8ed729ea2f253a5337d35343a527c82e74 (patch)
treecef04994cd7e6e94ad5672c763451de11d0d7de7 /gnu/packages/patches/flint-ldconfig.patch
parent91430de6dfb8b05989d64ad0b4e3f5a01f8cce2a (diff)
downloadguix-patches-6c591c8ed729ea2f253a5337d35343a527c82e74.tar
guix-patches-6c591c8ed729ea2f253a5337d35343a527c82e74.tar.gz
gnu: flint: Update to 2.5.2.
* gnu/packages/algebra.scm (flint): Update to 2.5.2. * gnu/packages/patches/flint-ldconfig.patch: New file. * gnu-system.am (dist_patch_DATA): Register the patch.
Diffstat (limited to 'gnu/packages/patches/flint-ldconfig.patch')
-rw-r--r--gnu/packages/patches/flint-ldconfig.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/flint-ldconfig.patch b/gnu/packages/patches/flint-ldconfig.patch
new file mode 100644
index 0000000000..d7c66e17ab
--- /dev/null
+++ b/gnu/packages/patches/flint-ldconfig.patch
@@ -0,0 +1,26 @@
+Patch by Andreas Enge <andreas@enge.fr>.
+Remedy the absence of ldconfig and explicitly create an additional symbolic
+link to the flint library, as discussed privately with upstream.
+
+diff -r -u flint-2.5.2.orig/configure flint-2.5.2/configure
+--- flint-2.5.2.orig/configure 2015-08-13 18:16:22.000000000 +0200
++++ flint-2.5.2/configure 2015-08-14 17:38:14.316284437 +0200
+@@ -714,6 +714,7 @@
+ echo "FLINT_SHARED=$SHARED" >> Makefile
+ echo "FLINT_LIB=$FLINT_LIB" >> Makefile
+ echo "FLINT_LIBNAME=$FLINT_LIBNAME" >> Makefile
++echo "FLINT_MAJOR=$FLINT_MAJOR" >> Makefile
+ echo "FLINT_SOLIB=$FLINT_SOLIB" >> Makefile
+ echo "EXEEXT=$EXEEXT" >> Makefile
+ echo "PREFIX=$PREFIX" >> Makefile
+diff -r -u flint-2.5.2.orig/Makefile.in flint-2.5.2/Makefile.in
+--- flint-2.5.2.orig/Makefile.in 2015-08-13 18:16:22.000000000 +0200
++++ flint-2.5.2/Makefile.in 2015-08-14 17:38:50.584774817 +0200
+@@ -118,6 +118,7 @@
+ $(LDCONFIG) -n "$(CURDIR)"; \
+ fi
+ ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME)"; \
++ ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME).$(FLINT_MAJOR)"; \
+
+ libflint.a: $(OBJS) $(LIB_SOURCES) $(EXT_SOURCES) $(HEADERS) $(EXT_HEADERS) | build build/interfaces
+ $(AT)$(foreach ext, $(EXTENSIONS), $(foreach dir, $(filter-out %templates, $(patsubst $(ext)/%.h, %, $(wildcard $(ext)/*.h))), mkdir -p build/$(dir); BUILD_DIR=$(CURDIR)/build/$(dir); export BUILD_DIR; MOD_DIR=$(dir); export MOD_DIR; $(MAKE) -f $(CURDIR)/Makefile.subdirs -C $(ext)/$(dir) static || exit $$?;))