summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-08-14 17:46:31 +0200
committerAndreas Enge <andreas@enge.fr>2015-08-14 18:14:33 +0200
commit6c591c8ed729ea2f253a5337d35343a527c82e74 (patch)
treecef04994cd7e6e94ad5672c763451de11d0d7de7
parent91430de6dfb8b05989d64ad0b4e3f5a01f8cce2a (diff)
downloadguix-patches-6c591c8ed729ea2f253a5337d35343a527c82e74.tar
guix-patches-6c591c8ed729ea2f253a5337d35343a527c82e74.tar.gz
gnu: flint: Update to 2.5.2.
* gnu/packages/algebra.scm (flint): Update to 2.5.2. * gnu/packages/patches/flint-ldconfig.patch: New file. * gnu-system.am (dist_patch_DATA): Register the patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/algebra.scm10
-rw-r--r--gnu/packages/patches/flint-ldconfig.patch26
3 files changed, 30 insertions, 7 deletions
diff --git a/gnu-system.am b/gnu-system.am
index f9db6acc51..849b93f064 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -444,6 +444,7 @@ dist_patch_DATA = \
gnu/packages/patches/findutils-localstatedir.patch \
gnu/packages/patches/flashrom-use-libftdi1.patch \
gnu/packages/patches/flex-bison-tests.patch \
+ gnu/packages/patches/flint-ldconfig.patch \
gnu/packages/patches/fltk-shared-lib-defines.patch \
gnu/packages/patches/fuse-CVE-2015-3202.patch \
gnu/packages/patches/gawk-shell.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2d0804acc6..d3fe345d30 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -189,14 +189,15 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(define-public flint
(package
(name "flint")
- (version "2.4.5")
+ (version "2.5.2")
(source (origin
(method url-fetch)
(uri (string-append
"http://flintlib.org/flint-"
version ".tar.gz"))
(sha256 (base32
- "1qq11sxliy499a9g656dgk47ffb951q4gl6ddjbq838gy16kb2g4"))))
+ "11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
+ (patches (map search-patch '("flint-ldconfig.patch")))))
(build-system gnu-build-system)
(propagated-inputs
`(("gmp" ,gmp)
@@ -209,11 +210,6 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(let ((out (assoc-ref outputs "out"))
(gmp (assoc-ref inputs "gmp"))
(mpfr (assoc-ref inputs "mpfr")))
- ;; Drop test failing with gmp-6 due to changed invertibility
- ;; of 0 in Z/1 Z, which according to the flint authors has no
- ;; impact on flint.
- ;; FIXME: Drop with later version.
- (delete-file "fmpz/test/t-invmod.c")
;; do not pass "--enable-fast-install", which makes the
;; homebrew configure process fail
(zero? (system*
diff --git a/gnu/packages/patches/flint-ldconfig.patch b/gnu/packages/patches/flint-ldconfig.patch
new file mode 100644
index 0000000000..d7c66e17ab
--- /dev/null
+++ b/gnu/packages/patches/flint-ldconfig.patch
@@ -0,0 +1,26 @@
+Patch by Andreas Enge <andreas@enge.fr>.
+Remedy the absence of ldconfig and explicitly create an additional symbolic
+link to the flint library, as discussed privately with upstream.
+
+diff -r -u flint-2.5.2.orig/configure flint-2.5.2/configure
+--- flint-2.5.2.orig/configure 2015-08-13 18:16:22.000000000 +0200
++++ flint-2.5.2/configure 2015-08-14 17:38:14.316284437 +0200
+@@ -714,6 +714,7 @@
+ echo "FLINT_SHARED=$SHARED" >> Makefile
+ echo "FLINT_LIB=$FLINT_LIB" >> Makefile
+ echo "FLINT_LIBNAME=$FLINT_LIBNAME" >> Makefile
++echo "FLINT_MAJOR=$FLINT_MAJOR" >> Makefile
+ echo "FLINT_SOLIB=$FLINT_SOLIB" >> Makefile
+ echo "EXEEXT=$EXEEXT" >> Makefile
+ echo "PREFIX=$PREFIX" >> Makefile
+diff -r -u flint-2.5.2.orig/Makefile.in flint-2.5.2/Makefile.in
+--- flint-2.5.2.orig/Makefile.in 2015-08-13 18:16:22.000000000 +0200
++++ flint-2.5.2/Makefile.in 2015-08-14 17:38:50.584774817 +0200
+@@ -118,6 +118,7 @@
+ $(LDCONFIG) -n "$(CURDIR)"; \
+ fi
+ ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME)"; \
++ ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME).$(FLINT_MAJOR)"; \
+
+ libflint.a: $(OBJS) $(LIB_SOURCES) $(EXT_SOURCES) $(HEADERS) $(EXT_HEADERS) | build build/interfaces
+ $(AT)$(foreach ext, $(EXTENSIONS), $(foreach dir, $(filter-out %templates, $(patsubst $(ext)/%.h, %, $(wildcard $(ext)/*.h))), mkdir -p build/$(dir); BUILD_DIR=$(CURDIR)/build/$(dir); export BUILD_DIR; MOD_DIR=$(dir); export MOD_DIR; $(MAKE) -f $(CURDIR)/Makefile.subdirs -C $(ext)/$(dir) static || exit $$?;))