summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 18:23:07 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 18:40:21 +0200
commitbb82c3d42bb95588f40394f4d71f915654c0e643 (patch)
treed223a529ea546571ca896571edcacfceba1f943b /gnu/packages/patches/emacs-fix-scheme-indent-function.patch
parented71cda2ac9f2b32beb359dfef49052f9e1b93fe (diff)
downloadguix-patches-bb82c3d42bb95588f40394f4d71f915654c0e643.tar
guix-patches-bb82c3d42bb95588f40394f4d71f915654c0e643.tar.gz
gnu: emacs: Update to 26.1.
* gnu/packages/emacs.scm (emacs): Update to 26.1, [arguments]: disable tests as they do not exist in release. * gnu/packages/patches/emacs-fix-scheme-indent-function.patch: Update patch indentation and line numbers.
Diffstat (limited to 'gnu/packages/patches/emacs-fix-scheme-indent-function.patch')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index c5a426802c..4b7904ea3b 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el
-@@ -482,6 +482,12 @@
- (> (length function) 3)
- (string-match "\\`def" function)))
- (lisp-indent-defform state indent-point))
+@@ -494,6 +494,12 @@ indentation."
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
+ ((and (null method)
+ (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function))
+ (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point)))
- ((integerp method)
- (lisp-indent-specform method state
- indent-point normal-indent))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))