summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 18:23:07 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 18:40:21 +0200
commitbb82c3d42bb95588f40394f4d71f915654c0e643 (patch)
treed223a529ea546571ca896571edcacfceba1f943b
parented71cda2ac9f2b32beb359dfef49052f9e1b93fe (diff)
downloadguix-patches-bb82c3d42bb95588f40394f4d71f915654c0e643.tar
guix-patches-bb82c3d42bb95588f40394f4d71f915654c0e643.tar.gz
gnu: emacs: Update to 26.1.
* gnu/packages/emacs.scm (emacs): Update to 26.1, [arguments]: disable tests as they do not exist in release. * gnu/packages/patches/emacs-fix-scheme-indent-function.patch: Update patch indentation and line numbers.
-rw-r--r--gnu/packages/emacs.scm7
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
2 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fc7f52a327..fbe188f4ef 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -114,14 +114,14 @@
(define-public emacs
(package
(name "emacs")
- (version "25.3")
+ (version "26.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/emacs/emacs-"
version ".tar.xz"))
(sha256
(base32
- "02y00y9q42g1iqgz5qhmsja75hwxd88yrn9zp14lanay0zkwafi5"))
+ "0b6k1wq44rc8gkvxhi1bbjxbz3cwg29qbq8mklq2az6p1hjgrx0w"))
(patches (search-patches "emacs-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
"emacs-source-date-epoch.patch"))
@@ -159,7 +159,8 @@
" ")))))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f ; no check target
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-/bin/pwd
(lambda _
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index c5a426802c..4b7904ea3b 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el
-@@ -482,6 +482,12 @@
- (> (length function) 3)
- (string-match "\\`def" function)))
- (lisp-indent-defform state indent-point))
+@@ -494,6 +494,12 @@ indentation."
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
+ ((and (null method)
+ (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function))
+ (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point)))
- ((integerp method)
- (lisp-indent-specform method state
- indent-point normal-indent))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))