summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:30:54 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:27:31 +0100
commitf3b98f4fec43c951a9e28c67561395992bf190a7 (patch)
treeabda762491df7d66f0f41332b20739ca41c22aa1 /gnu/packages/openstack.scm
parent5d8549328483978bf04dd2c710ef6a06614d4776 (diff)
downloadguix-patches-f3b98f4fec43c951a9e28c67561395992bf190a7.tar
guix-patches-f3b98f4fec43c951a9e28c67561395992bf190a7.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 2)
This patch contains the changes where removing setuptools from the inputs affected some code-lines beside. * gnu/packages/admin.scm (ansible): Remove all [inputs], [native-inputs] and [propagated-inputs] where python-setuptools or python2-setuptools are the sole entries. Remove python-setuptools and python2-setuptools listed on a line by its own from [inputs], [native-inputs] and [propagated-inputs]. * gnu/packages/backup.scm (duplicity): Likewise. * gnu/packages/bioinformatics.scm (bamm, python2-pybedtools, python2-bx-python, python2-dendropy, python-pysam, python2-pysam, clipper, crossmap, cutadapt, deeptools, grit, idr, python2-warpedlmm, pbtranscript-tofu, seqmagick): Likewise. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/freedesktop.scm (python-pyxdg, python2-pyxdg): Likewise. * gnu/packages/lirc.scm (python2-lirc): Likewise. * gnu/packages/mp3.scm (eyed3): Likewise. * gnu/packages/nutrition.scm (gourmet): Likewise. * gnu/packages/openstack.scm (python-hacking, python2-hacking, python-os-testr, python2-os-testr, python-stevedore, python2-stevedore, python-tempest-lib, python2-tempest-lib, python-oslo.log, python2-oslo.log, python-keystoneclient, python2-keystoneclient): Likewise. * gnu/packages/password-utils.scm (assword): Likewise. * gnu/packages/python.scm (python-passlib, python2-passlib, python-babel, python2-babel, python-parse-type, python-pytest, python2-pytest, python-scripttest, python2-scripttest, python-testtools, python2-testtools, python-testscenarios, python2-testscenarios, python-subunit, python2-subunit, python-pbr-0.11, python-pbr, python2-pbr, python-testrepository, python2-testrepository, behave, python-wheel, python2-wheel, python-requests, python2-requests, python-jsonschema, python2-jsonschema, python-pyjwt, python2-pyjwt, python-virtualenv, python2-virtualenv, python-jinja2, python2-jinja2, python-joblib, python2-joblib, python-sphinx, python2-sphinx, python-feedgenerator, python2-feedgenerator, python-scikit-image, python2-scikit-image, python-redis, python2-redis, python2-fastlmm, python-numpydoc, python2-numpydoc, python-matplotlib, python2-matplotlib, python2-pysnptools, python-rpy2, python2-rpy2, python-pillow, python2-pillow, python-pycparser, python2-pycparser, python-cffi, python2-cffi, python-cairocffi, python2-cairocffi, python-drmaa, python2-drmaa, python-pathpy, python2-pathpy, python-simplegeneric, python2-simplegeneric, python-ipython, python2-ipython, python-apsw, python2-apsw, python-lxml, python2-lxml, python-networkx, python2-networkx, python-pyzmq, python2-pyzmq, python-mccabe, python2-mccabe, python-mccabe-0.2.1, python-flake8, python2-flake8, python-flake8-2.2.4, python-mistune, python2-mistune, python-ptyprocess, python2-ptyprocess, python-llfuse, python2-llfuse, python-webob, python2-webob, python-xlrd, python2-xlrd, python-tables, python2-tables, python-pip, python2-pip, python-libarchive-c, python2-libarchive-c, python-docopt, python2-docopt, python-pyrfc3339, python2-pyrfc3339, python-configobj, python2-configobj, python-clint, python2-clint, python-rply, python2-rply, python2-rpython, python-widgetsnbextension, python2-widgetsnbextension jupyter, python-jupyter-console, python2-jupyter-console, python-hy, python2-hy, python-urllib3, python2-urllib3, python-rsa, python2-rsa, python-tox, python2-tox, python2-hypothesis, python-paste, python2-paste, python-pastescript, python2-pastescript, python2-unicodecsv, python-pkgconfig, python2-pkgconfig, python2-rope, python-sqlparse, python2-sqlparse, python-gevent, python2-gevent, python-tabulate, python2-tabulate, python-arrow, python2-arrow, python-cleo, python2-cleo, python-fake-factory, python2-fake-factory, ptpython): Likewise. * gnu/packages/rdf.scm (python-rdflib, python2-rdflib): Likewise. * gnu/packages/terminals.scm (asciinema): Likewise. * gnu/packages/version-control.scm (git-annex-remote-hubic): Likewise. * gnu/packages/xdisorg.scm (arandr): Likewise.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index e216ed06f0..930ce9eceb 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -121,8 +121,7 @@ manner.")
("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
("python-six" ,python-six)))
(inputs
- `(("python-setuptools" ,python-setuptools)
- ;; Tests
+ `(;; Tests
("python-testscenarios" ,python-testscenarios)))
(home-page "http://github.com/openstack-dev/hacking")
(synopsis "OpenStack hacking guideline enforcement")
@@ -221,8 +220,7 @@ tested on Python version 3.2, 2.7 and 2.6.")
("python-subunit" ,python-subunit)
("python-testtools" ,python-testtools)))
(inputs
- `(("python-babel" ,python-babel)
- ("python-setuptools" ,python-setuptools)))
+ `(("python-babel" ,python-babel)))
(home-page "https://www.openstack.org/")
(synopsis "Testr wrapper to provide functionality for OpenStack projects")
(description
@@ -291,8 +289,7 @@ portions of your testing code.")
(inputs
`(("python-pbr" ,python-pbr)))
(native-inputs
- `(("python-setuptools" ,python-setuptools)
- ;; Tests
+ `(;; Tests
("python-docutils" ,python-docutils)
("python-mock" ,python-mock)
("python-oslotest" ,python-oslotest)
@@ -346,8 +343,7 @@ extensions.")
`(("python-babel" ,python-babel)
("python-mock" ,python-mock)
("python-os-testr" ,python-os-testr)
- ("python-oslotest" ,python-oslotest)
- ("python-setuptools" ,python-setuptools)))
+ ("python-oslotest" ,python-oslotest)))
(home-page "https://www.openstack.org/")
(synopsis "OpenStack functional testing library")
(description
@@ -484,8 +480,7 @@ in an application or library.")
("python-iso8601" ,python-iso8601)
("python-mock" ,python-mock)
("python-oslotest" ,python-oslotest)
- ("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)))
+ ("python-pbr" ,python-pbr)))
(home-page "http://launchpad.net/oslo")
(synopsis "Python logging library of the Oslo project")
(description
@@ -657,8 +652,7 @@ handling.")
"1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
(build-system python-build-system)
(native-inputs
- `(("python-setuptools" ,python-setuptools)
- ("python-sphinx" ,python-sphinx)
+ `(("python-sphinx" ,python-sphinx)
;; and some packages for the tests
("openssl" ,openssl)
("python-coverage" ,python-coverage)