summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:18:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 21:58:44 +0100
commit5d8549328483978bf04dd2c710ef6a06614d4776 (patch)
treea78aa30b1cad46da683f79f32ec7d1935c3c2784 /gnu/packages/openstack.scm
parentf54d6bacbf46f5f25d3f7a5bea578879ee865be1 (diff)
downloadguix-patches-5d8549328483978bf04dd2c710ef6a06614d4776.tar
guix-patches-5d8549328483978bf04dd2c710ef6a06614d4776.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 1b)
This patch contains the changes in all modules beside python.scm where removing setuptools from the inputs could be achieved by removing complete lines. * gnu/packages/admin.scm (graphios, thefuck): Remove all [inputs], [native-inputs] and [propagated-inputs] where python-setuptools or python2-setuptools are the sole entries. Remove python-setuptools and python2-setuptools listed on a line by its own from [inputs], [native-inputs] and [propagated-inputs]. * gnu/packages/backup.scm (rdiff-backup): Likewise. * gnu/packages/bioinformatics.scm (htseq, macs, python2-pbcore, rseqc, multiqc): Likewise. * gnu/packages/django.scm (python-django, python2-django, python-django-simple-math-captcha, python2-django-simple-math-captcha): Likewise. * gnu/packages/docker.scm (python-docker-py, docker-compose): Likewise. * gnu/packages/game-development.scm (python-pygame): Likewise. * gnu/packages/key-mon.scm (key-mon): Likewise. * gnu/packages/mail.scm (khard): Likewise. * gnu/packages/music.scm (beets, python2-pyechonest): Likewise. * gnu/packages/openstack.scm (python-bandit, python2-bandit, python-debtcollector, python2-debtcollector, python-mox3, python2-mox3, python-os-client-config, python2-os-client-config, python-oslo.config, python2-oslo.config, python-oslo.context, python2-oslo.context, python-oslo.i18n, python2-oslo.i18n, python-oslo.serialization, python2-oslo.serialization, python-oslosphinx, python2-oslosphinx, python-oslotest, python2-oslotest, python-oslo.utils, python2-oslo.utils, python-swiftclient, python2-swiftclient): Likewise. * gnu/packages/pdf.scm (pdfposter): Likewise. * gnu/packages/tls.scm (python-acme, python2-acme): Likewise.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 43a6490b22..e216ed06f0 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -51,7 +51,6 @@
("python-stevedore" ,python-stevedore)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-fixtures" ,python-fixtures)
("python-mock" ,python-mock)
@@ -88,7 +87,6 @@ all the files it generates a report.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)))
(home-page "http://www.openstack.org/")
@@ -152,7 +150,6 @@ guidelines}.")
(native-inputs
`(("python-fixtures" ,python-fixtures)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
("python-six" ,python-six)
("python-testtools" ,python-testtools)))
(home-page "http://www.openstack.org/")
@@ -188,7 +185,6 @@ tested on Python version 3.2, 2.7 and 2.6.")
("python-pbr" ,python-pbr)
("python-pyyaml" ,python-pyyaml)
("python-testrepository" ,python-testrepository)
- ("python-setuptools" ,python-setuptools)
("python-testscenarios" ,python-testscenarios)
("python-testtools" ,python-testtools)))
(home-page "http://www.openstack.org/")
@@ -384,7 +380,6 @@ common features used in Tempest.")
("python-stevedore" ,python-stevedore)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-oslo.i18n" ,python-oslo.i18n)
("python-mock" ,python-mock)
@@ -415,7 +410,6 @@ common features used in Tempest.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)))
(home-page "http://launchpad.net/oslo")
@@ -446,7 +440,6 @@ pipeline and used by various modules such as logging.")
("python-six" ,python-six)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-mock" ,python-mock)
("python-mox3" ,python-mox3)
@@ -526,7 +519,6 @@ handlers and support for context specific logging (like resource id’s etc).")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-mock" ,python-mock)
("python-oslo.i18n" ,python-oslo.i18n)
@@ -559,7 +551,6 @@ in transmittable and storable formats, such as JSON and MessagePack.")
`(("python-pbr" ,python-pbr)
("python-docutils" ,python-docutils)
("python-hacking" ,python-hacking)
- ("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)))
(home-page "http://www.openstack.org/")
(synopsis "OpenStack sphinx extensions and theme")
@@ -594,7 +585,6 @@ from the OpenStack project.")
(inputs
`(("python-pbr" ,python-pbr)
("python-os-client-config" ,python-os-client-config)
- ("python-setuptools" ,python-setuptools)
("python-subunit" ,python-subunit)
("python-testrepository" ,python-testrepository)
("python-testscenarios" ,python-testscenarios)
@@ -638,7 +628,6 @@ and better support for mocking results.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)
("python-mock" ,python-mock)
@@ -744,7 +733,6 @@ LDAP.")
(build-system python-build-system)
(native-inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)
;; The folloing packages are needed for the tests.
("python-coverage" ,python-coverage)