summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:18:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 21:58:44 +0100
commit5d8549328483978bf04dd2c710ef6a06614d4776 (patch)
treea78aa30b1cad46da683f79f32ec7d1935c3c2784 /gnu
parentf54d6bacbf46f5f25d3f7a5bea578879ee865be1 (diff)
downloadguix-patches-5d8549328483978bf04dd2c710ef6a06614d4776.tar
guix-patches-5d8549328483978bf04dd2c710ef6a06614d4776.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 1b)
This patch contains the changes in all modules beside python.scm where removing setuptools from the inputs could be achieved by removing complete lines. * gnu/packages/admin.scm (graphios, thefuck): Remove all [inputs], [native-inputs] and [propagated-inputs] where python-setuptools or python2-setuptools are the sole entries. Remove python-setuptools and python2-setuptools listed on a line by its own from [inputs], [native-inputs] and [propagated-inputs]. * gnu/packages/backup.scm (rdiff-backup): Likewise. * gnu/packages/bioinformatics.scm (htseq, macs, python2-pbcore, rseqc, multiqc): Likewise. * gnu/packages/django.scm (python-django, python2-django, python-django-simple-math-captcha, python2-django-simple-math-captcha): Likewise. * gnu/packages/docker.scm (python-docker-py, docker-compose): Likewise. * gnu/packages/game-development.scm (python-pygame): Likewise. * gnu/packages/key-mon.scm (key-mon): Likewise. * gnu/packages/mail.scm (khard): Likewise. * gnu/packages/music.scm (beets, python2-pyechonest): Likewise. * gnu/packages/openstack.scm (python-bandit, python2-bandit, python-debtcollector, python2-debtcollector, python-mox3, python2-mox3, python-os-client-config, python2-os-client-config, python-oslo.config, python2-oslo.config, python-oslo.context, python2-oslo.context, python-oslo.i18n, python2-oslo.i18n, python-oslo.serialization, python2-oslo.serialization, python-oslosphinx, python2-oslosphinx, python-oslotest, python2-oslotest, python-oslo.utils, python2-oslo.utils, python-swiftclient, python2-swiftclient): Likewise. * gnu/packages/pdf.scm (pdfposter): Likewise. * gnu/packages/tls.scm (python-acme, python2-acme): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm4
-rw-r--r--gnu/packages/backup.scm2
-rw-r--r--gnu/packages/bioinformatics.scm8
-rw-r--r--gnu/packages/django.scm6
-rw-r--r--gnu/packages/docker.scm2
-rw-r--r--gnu/packages/game-development.scm2
-rw-r--r--gnu/packages/key-mon.scm2
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/music.scm2
-rw-r--r--gnu/packages/openstack.scm12
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/tls.scm1
12 files changed, 0 insertions, 45 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5adde6cc4a..b0edc69cad 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1332,8 +1332,6 @@ specified directories.")
(("/usr") out)
(("distro_ver = .*") "distro_ver = ''"))
#t))))))
- (inputs
- `(("python-setuptools" ,python2-setuptools)))
(home-page "https://github.com/shawn-sterling/graphios")
(synopsis "Emit Nagios metrics to Graphite, Statsd, and Librato")
(description
@@ -1699,8 +1697,6 @@ throughput (in the same interval).")
(base32
"04q2cn8c83f6z6wn1scla1ilrpi5ssjc64987hvmwfvwvb82bvkp"))))
(build-system python-build-system)
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(inputs
`(("python-colorama" ,python-colorama)
("python-decorator" ,python-decorator)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 203ff4c9dc..5b1706ea12 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -339,8 +339,6 @@ errors.")
(base32
"1nwmmh816f96h0ff1jxk95ad38ilbhbdl5dgibx1d4cl81dsi48d"))))
(build-system python-build-system)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(inputs
`(("python" ,python-2)
("librsync" ,librsync)))
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5444f0a2a1..8377e811db 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2814,8 +2814,6 @@ HMMs).")
`(("python-numpy" ,python2-numpy)))
(inputs
`(("python-pysam" ,python2-pysam)))
- (native-inputs
- `(("python-setuptools" ,python2-setuptools)))
(home-page "http://www-huber.embl.de/users/anders/HTSeq/")
(synopsis "Analysing high-throughput sequencing data with Python")
(description
@@ -3094,8 +3092,6 @@ data.")
#:tests? #f)) ; no test target
(inputs
`(("python-numpy" ,python2-numpy)))
- (native-inputs
- `(("python-setuptools" ,python2-setuptools)))
(home-page "http://github.com/taoliu/MACS/")
(synopsis "Model based analysis for ChIP-Seq data")
(description
@@ -3521,7 +3517,6 @@ interrupted by stop codons. OrfM finds and prints these ORFs.")
(native-inputs
`(("python-docutils" ,python2-docutils)
("python-nose" ,python2-nose)
- ("python-setuptools" ,python2-setuptools)
("python-sphinx" ,python2-sphinx)))
(propagated-inputs
`(("python-pyxb" ,python2-pyxb)))
@@ -4028,7 +4023,6 @@ BAM and Wiggle files in both transcript-coordinate and genomic-coordinate.")
`(("python-cython" ,python2-cython)
("python-pysam" ,python2-pysam)
("python-numpy" ,python2-numpy)
- ("python-setuptools" ,python2-setuptools)
("zlib" ,zlib)))
(native-inputs
`(("python-nose" ,python2-nose)))
@@ -7696,8 +7690,6 @@ replacement for strverscmp.")
("python-click" ,python-click)
("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(home-page "http://multiqc.info")
(synopsis "Aggregate bioinformatics analysis reports")
(description
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index f56ed58363..1ab2094dce 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -54,10 +54,6 @@
(string-append ".:" (getenv "PYTHONPATH")))
(zero? (system* "python" "tests/runtests.py")))))))
;; TODO: Install extras/django_bash_completion.
- (propagated-inputs
- ;; Django uses 'pkg_resources' (part of setuptools) to locate templates
- ;; at run-time.
- `(("python-setuptools" ,python-setuptools)))
(native-inputs
`(("tzdata", tzdata)
;; bcrypt and argon2-cffi are extra requirements not yet in guix
@@ -112,8 +108,6 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
(build-system python-build-system)
(propagated-inputs
`(("python-django" ,python-django)))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/alsoicode/django-simple-math-captcha")
(synopsis "Easy-to-use math field/widget captcha for Django forms")
(description
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 0760001da7..3cfdb7ef55 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -42,7 +42,6 @@
(arguments '(#:tests? #f))
(inputs
`(("python-requests" ,python-requests)
- ("python-setuptools" ,python-setuptools)
("python-six" ,python-six)
("python-websocket-client" ,python-websocket-client)))
(home-page "https://github.com/docker/docker-py/")
@@ -93,7 +92,6 @@ client.")
("python-jsonschema" ,python-jsonschema)
("python-pyyaml" ,python-pyyaml)
("python-requests" ,python-requests-2.7)
- ("python-setuptools" ,python-setuptools)
("python-six" ,python-six)
("python-texttable" ,python-texttable)
("python-websocket-client" ,python-websocket-client)))
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 76c06ecc72..e83294d9c4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -591,8 +591,6 @@ interface (API).")
(string-append v4l-ref "/include/libv4l1-videodev.h")
"linux/videodev.h")
(system* "ln" "--symbolic" "Setup.in" "Setup")))))))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(inputs
`(("sdl" ,sdl)
("sdl-image" ,sdl-image)
diff --git a/gnu/packages/key-mon.scm b/gnu/packages/key-mon.scm
index c76360ce08..6237a1765a 100644
--- a/gnu/packages/key-mon.scm
+++ b/gnu/packages/key-mon.scm
@@ -42,8 +42,6 @@
(arguments
`(#:python ,python-2 ;uses the Python 2 'print' syntax
#:tests? #f)) ;no tests
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(inputs
`(("python2-xlib" ,python2-xlib)
("python2-pygtk" ,python2-pygtk)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a485c1f5c3..a152d50c36 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1367,8 +1367,6 @@ maintained.")
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/khard")))
(copy-recursively "misc/khard" doc)))))))
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(propagated-inputs
`(("python2-vobject" ,python2-vobject)
("python2-pyyaml" ,python2-pyyaml)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index abcc498599..d25c9c419a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1787,7 +1787,6 @@ MusicBrainz database.")
`(;; Python 3 is not supported:
;; https://github.com/echonest/pyechonest/issues/42
#:python ,python-2))
- (native-inputs `(("python2-setuptools" ,python2-setuptools)))
(home-page "https://github.com/echonest/pyechonest")
(synopsis "Python interface to The Echo Nest APIs")
(description "Pyechonest is a Python library for the Echo Nest API. With
@@ -1863,7 +1862,6 @@ websites such as Libre.fm.")
(native-inputs
`(("python2-beautifulsoup4" ,python2-beautifulsoup4)
("python2-flask" ,python2-flask)
- ("python2-setuptools" ,python2-setuptools)
("python2-mock" ,python2-mock)
("python2-mpd2" ,python2-mpd2)
("python2-nose" ,python2-nose)
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 43a6490b22..e216ed06f0 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -51,7 +51,6 @@
("python-stevedore" ,python-stevedore)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-fixtures" ,python-fixtures)
("python-mock" ,python-mock)
@@ -88,7 +87,6 @@ all the files it generates a report.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)))
(home-page "http://www.openstack.org/")
@@ -152,7 +150,6 @@ guidelines}.")
(native-inputs
`(("python-fixtures" ,python-fixtures)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
("python-six" ,python-six)
("python-testtools" ,python-testtools)))
(home-page "http://www.openstack.org/")
@@ -188,7 +185,6 @@ tested on Python version 3.2, 2.7 and 2.6.")
("python-pbr" ,python-pbr)
("python-pyyaml" ,python-pyyaml)
("python-testrepository" ,python-testrepository)
- ("python-setuptools" ,python-setuptools)
("python-testscenarios" ,python-testscenarios)
("python-testtools" ,python-testtools)))
(home-page "http://www.openstack.org/")
@@ -384,7 +380,6 @@ common features used in Tempest.")
("python-stevedore" ,python-stevedore)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-oslo.i18n" ,python-oslo.i18n)
("python-mock" ,python-mock)
@@ -415,7 +410,6 @@ common features used in Tempest.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)))
(home-page "http://launchpad.net/oslo")
@@ -446,7 +440,6 @@ pipeline and used by various modules such as logging.")
("python-six" ,python-six)))
(inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests
("python-mock" ,python-mock)
("python-mox3" ,python-mox3)
@@ -526,7 +519,6 @@ handlers and support for context specific logging (like resource id’s etc).")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-mock" ,python-mock)
("python-oslo.i18n" ,python-oslo.i18n)
@@ -559,7 +551,6 @@ in transmittable and storable formats, such as JSON and MessagePack.")
`(("python-pbr" ,python-pbr)
("python-docutils" ,python-docutils)
("python-hacking" ,python-hacking)
- ("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)))
(home-page "http://www.openstack.org/")
(synopsis "OpenStack sphinx extensions and theme")
@@ -594,7 +585,6 @@ from the OpenStack project.")
(inputs
`(("python-pbr" ,python-pbr)
("python-os-client-config" ,python-os-client-config)
- ("python-setuptools" ,python-setuptools)
("python-subunit" ,python-subunit)
("python-testrepository" ,python-testrepository)
("python-testscenarios" ,python-testscenarios)
@@ -638,7 +628,6 @@ and better support for mocking results.")
(inputs
`(("python-babel" ,python-babel)
("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
;; Tests.
("python-oslotest" ,python-oslotest)
("python-mock" ,python-mock)
@@ -744,7 +733,6 @@ LDAP.")
(build-system python-build-system)
(native-inputs
`(("python-pbr" ,python-pbr)
- ("python-setuptools" ,python-setuptools)
("python-sphinx" ,python-sphinx)
;; The folloing packages are needed for the tests.
("python-coverage" ,python-coverage)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9c6e9a967e..171f1990f7 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -874,8 +874,6 @@ python-pypdf2 instead.")
(inputs
;; pdfposter 0.6.0 still uses the old pyPdf
`(("python2-pypdf" ,python2-pypdf)))
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)))
(home-page "https://pythonhosted.org/pdftools.pdfposter/")
(synopsis "Scale and tile PDF images/pages to print on multiple pages")
(description "@command{pdfposter} can be used to create a large poster by
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 74cc25bb67..608fd6a080 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -462,7 +462,6 @@ security, and applying best practice development processes.")
("python-sphinx" ,python-sphinx)
("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("python-setuptools" ,python-setuptools)
("texinfo" ,texinfo)))
(propagated-inputs
`(("python-ndg-httpsclient" ,python-ndg-httpsclient)