summaryrefslogtreecommitdiff
path: root/gnu/packages/openpgp.scm
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-07-23 14:03:19 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-24 14:21:31 +0200
commit39222080911eaf3d7f74effe4467c1a04464aef3 (patch)
treeb6e3e02c05eaf7f86efe8ec6bb5cc4e8f8ba7b46 /gnu/packages/openpgp.scm
parentd51cb7f85f051b02d6e59829a7f9eb30ff044ad5 (diff)
downloadguix-patches-39222080911eaf3d7f74effe4467c1a04464aef3.tar
guix-patches-39222080911eaf3d7f74effe4467c1a04464aef3.tar.gz
gnu: Add dkgpg.
* gnu/packages/openpgp.scm (dkgpg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/openpgp.scm')
-rw-r--r--gnu/packages/openpgp.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
index d3cb9027f7..94beab9929 100644
--- a/gnu/packages/openpgp.scm
+++ b/gnu/packages/openpgp.scm
@@ -21,6 +21,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages multiprecision))
@@ -53,3 +54,41 @@ been studied since 1979 (Shamir, Rivest, and Adleman) by many authors.
LibTMCG provides the first practical implementation of such protocols.")
(home-page "https://www.nongnu.org/libtmcg/")
(license license:gpl2+)))
+
+(define-public dkgpg
+ (package
+ (name "dkgpg")
+ (version "1.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/dkgpg/dkgpg-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1hpfg7akd5icj49i03z74hp9zj0xwl90bndn0hnw0hpb8lk7qcxg"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags
+ '("--enable-silent-rules")
+ ;; https://savannah.nongnu.org/bugs/?58772
+ #:parallel-tests? #f))
+ (inputs `(("bzip2" ,bzip2)
+ ("gmp" ,gmp)
+ ("libgcrypt" ,libgcrypt)
+ ("libtmcg" ,libtmcg)
+ ("zlib" ,zlib)))
+ (synopsis
+ "Distributed Key Generation and Threshold Cryptography for OpenPGP")
+ (description
+ "The Distributed Privacy Guard (DKGPG) implements Distributed Key
+Generation (DKG) and Threshold Cryptography for OpenPGP. The generated public
+keys are compatible with the standard and thus can be used by any
+RFC4880-compliant application (e.g. GnuPG). The main purposes of this
+software are distributing power among multiple parties, eliminating single
+points of failure, and increasing the difficulty of side-channel attacks on
+private key material.
+
+DKGPG consists of a bunch of simple command-line programs. The current
+implementation is in experimental state and should NOT be used in production
+environments.")
+ (home-page "https://www.nongnu.org/dkgpg/")
+ (license license:gpl2+)))