summaryrefslogtreecommitdiff
path: root/gnu/packages/openpgp.scm
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-07-23 14:03:18 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-24 14:21:31 +0200
commitd51cb7f85f051b02d6e59829a7f9eb30ff044ad5 (patch)
treed0ed14b69945fa0c959e6e070ad3be00279a37d1 /gnu/packages/openpgp.scm
parentac928d3e9ebdb660f8104f3e4b890a2353787cdf (diff)
downloadguix-patches-d51cb7f85f051b02d6e59829a7f9eb30ff044ad5.tar
guix-patches-d51cb7f85f051b02d6e59829a7f9eb30ff044ad5.tar.gz
gnu: Add libtmcg.
* gnu/packages/openpgp.scm: New file. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/openpgp.scm')
-rw-r--r--gnu/packages/openpgp.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
new file mode 100644
index 0000000000..d3cb9027f7
--- /dev/null
+++ b/gnu/packages/openpgp.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages openpgp)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages multiprecision))
+
+(define-public libtmcg
+ (package
+ (name "libtmcg")
+ (version "1.3.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/libtmcg/libTMCG-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "179b5jx3mqs9hgsj8cfwk6x8qib60kw9szk9fkz6s1gl3v83mnyx"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("--enable-silent-rules")))
+ (inputs `(("gmp" ,gmp)
+ ("libgcrypt" ,libgcrypt)))
+ (synopsis
+ "C++ library for creating secure and fair online card games")
+ (description
+ "The library provides a sort of useful classes, algorithms, and
+high-level protocols to support an application programmer in writing such
+software. The most remarkable feature is the absence of a trusted third
+party (TTP), i.e. neither a central game server nor trusted hardware
+components are necessary.
+
+The corresponding cryptographic problem, actually called Mental Poker, has
+been studied since 1979 (Shamir, Rivest, and Adleman) by many authors.
+LibTMCG provides the first practical implementation of such protocols.")
+ (home-page "https://www.nongnu.org/libtmcg/")
+ (license license:gpl2+)))