summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2021-06-17 08:28:14 +0200
committerBrice Waegeneire <brice@waegenei.re>2021-06-17 08:28:14 +0200
commitd65bd74411ab4820318311062b0f327b139a5784 (patch)
treec71ba724651cae4e662e077714de820b147e499a /gnu/packages/ntp.scm
parent76a9bad380111493b5a1422485f941de799c6c90 (diff)
downloadguix-patches-d65bd74411ab4820318311062b0f327b139a5784.tar
guix-patches-d65bd74411ab4820318311062b0f327b139a5784.tar.gz
gnu: openntpd: Get libressl version from the inputs.
* gnu/packages/ntp.scm (openntpd)[arguments]: Get libressl version from the package inputs.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index ed852f94cf..191eedd158 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -190,7 +190,9 @@ computers over a network.")
(arguments
`(#:configure-flags
(let* ((libressl (assoc-ref %build-inputs "libressl"))
- (libressl-version ,(package-version libressl)))
+ (libressl-version ,(package-version
+ (car (assoc-ref (package-inputs this-package)
+ "libressl")))))
(list "--with-privsep-user=ntpd"
"--localstatedir=/var"
(string-append "--with-cacert=" libressl