summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2021-06-11 23:14:47 +0200
committerBrice Waegeneire <brice@waegenei.re>2021-06-17 08:14:47 +0200
commit76a9bad380111493b5a1422485f941de799c6c90 (patch)
treed095a4d4e13bade7cff30ad85556d32cd79b0fa8 /gnu/packages/ntp.scm
parentdb87a223fe9f982ef9adf67fe7f24339eac70fcd (diff)
downloadguix-patches-76a9bad380111493b5a1422485f941de799c6c90.tar
guix-patches-76a9bad380111493b5a1422485f941de799c6c90.tar.gz
gnu: libressl: Remove search paths.
Unlike OpenSSL, LibreSSL hardcode it's certificate bundle and doesn't allow to specify it through a environment variable. * gnu/packages/tls.scm (libressl)[configure-flags]: Specify OpenSSL configuration directory. [native-search-paths]: Remove it. * gnu/packages/ntp.scm (openntpd)[configure-flags]: Adjust CAcert location.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index b86def1929..ed852f94cf 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -187,11 +188,14 @@ computers over a network.")
"0ijsylc7a4jlpxsqa0jq1w1c7333id8pcakzl7a5749ria1xp0l5"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags `( "--with-privsep-user=ntpd"
- "--localstatedir=/var"
- ,(string-append "--with-cacert="
- (assoc-ref %build-inputs "libressl")
- "/etc/ssl/cert.pem"))
+ `(#:configure-flags
+ (let* ((libressl (assoc-ref %build-inputs "libressl"))
+ (libressl-version ,(package-version libressl)))
+ (list "--with-privsep-user=ntpd"
+ "--localstatedir=/var"
+ (string-append "--with-cacert=" libressl
+ "/share/libressl-" libressl-version
+ "/cert.pem")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'modify-install-locations