summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-13 22:04:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 09:39:54 +0200
commitd1095c47f1bedcc10f8bc10d80b7f2de3ad8989b (patch)
tree225b0f5721deb7be51b7ead90f7249019caca5d4 /gnu/packages/node-xyz.scm
parentc8bbff7ee13b6c2b1a97edcf530685216955b471 (diff)
downloadguix-patches-d1095c47f1bedcc10f8bc10d80b7f2de3ad8989b.tar
guix-patches-d1095c47f1bedcc10f8bc10d80b7f2de3ad8989b.tar.gz
gnu: Add node-util-deprecate.
* gnu/packages/node-xyz.scm (node-util-deprecate): New variable.
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9a874f57b8..3e115970a5 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -112,3 +112,25 @@ random number generator.")
(description "This package provides a streaming parser for the statsd
protocol used in @code{node-lynx}.")
(license license:asl2.0)))
+
+(define-public node-util-deprecate
+ (package
+ (name "node-util-deprecate")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TooTallNate/util-deprecate")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rk94nl3qc7znsk8400bnga30v0m7j2mmvz9ldwjinxv1d3n11xc"))))
+ (build-system node-build-system)
+ (arguments '(#:tests? #f)) ; No test suite.
+ (home-page "https://github.com/TooTallNate/util-deprecate")
+ (synopsis "Node.js `util.deprecate()` function with browser support")
+ (description "This package provides the Node.js @code{util.deprecate()}
+function with browser support.")
+ (license license:expat)))