summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-13 22:04:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 09:39:53 +0200
commitc8bbff7ee13b6c2b1a97edcf530685216955b471 (patch)
tree4a1e9ce8ca0a5d6269e67c86fc9f7a9e34287367 /gnu/packages/node-xyz.scm
parenta971890b1da4543455d079b105364c390301986e (diff)
downloadguix-patches-c8bbff7ee13b6c2b1a97edcf530685216955b471.tar
guix-patches-c8bbff7ee13b6c2b1a97edcf530685216955b471.tar.gz
gnu: Add node-statsd-parser.
* gnu/packages/node-xyz.scm (node-statsd-parser): New variable.
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 5040c8db91..9a874f57b8 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -90,3 +90,25 @@ user-land JavaScript.")
(description "Thix package provides a node.js port of the Mersenne Twister
random number generator.")
(license license:bsd-3)))
+
+(define-public node-statsd-parser
+ (package
+ (name "node-statsd-parser")
+ (version "0.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dscape/statsd-parser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "049rnczsd6pv6bk282q4w72bhqc5cs562djgr7yncy7lk0wzq5j3"))))
+ (build-system node-build-system)
+ (arguments '(#:tests? #f)) ; No tests.
+ (home-page "https://github.com/dscape/statsd-parser")
+ (synopsis "Streaming parser for the statsd protocol")
+ (description "This package provides a streaming parser for the statsd
+protocol used in @code{node-lynx}.")
+ (license license:asl2.0)))