summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-04 22:23:48 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-04 22:23:48 +0100
commit9b1bf33081652210502c6ef34506e27a9bc60f06 (patch)
tree4997c1c0a781780e3a19605b88285bd1f89de5c9 /gnu/packages/ncurses.scm
parentd8491ba5630d31a58b89dfe5d423988ce736266b (diff)
downloadguix-patches-9b1bf33081652210502c6ef34506e27a9bc60f06.tar
guix-patches-9b1bf33081652210502c6ef34506e27a9bc60f06.tar.gz
gnu: Remove a bunch of now unneeded '--mandir' configure flags.
This has become redundant with the 'validate-documentation-location' phase introduced in commit d68fe74. * gnu/packages/compression.scm (bzip2): Remove 'fix-man-dir' phase. * gnu/packages/ncurses.scm (ncurses)[arguments]: Remove --mandir. * gnu/packages/pth.scm (pth)[arguments]: Remove #:configure-flags. * gnu/packages/tcl.scm (tcl)[arguments]: Likewise. * gnu/packages/xiph.scm (flac)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index de7e6f6721..0dbc583f79 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -99,11 +99,6 @@
,(string-append "--includedir=" (assoc-ref %outputs "out")
"/include")
- ;; By default man pages land in PREFIX/man, but we want them
- ;; in PREFIX/share/man.
- ,(string-append "--mandir=" (assoc-ref %outputs "out")
- "/share/man")
-
;; Make sure programs like 'tic', 'reset', and 'clear' have a
;; correct RUNPATH.
,(string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")