summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-04 22:23:48 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-04 22:23:48 +0100
commit9b1bf33081652210502c6ef34506e27a9bc60f06 (patch)
tree4997c1c0a781780e3a19605b88285bd1f89de5c9 /gnu
parentd8491ba5630d31a58b89dfe5d423988ce736266b (diff)
downloadguix-patches-9b1bf33081652210502c6ef34506e27a9bc60f06.tar
guix-patches-9b1bf33081652210502c6ef34506e27a9bc60f06.tar.gz
gnu: Remove a bunch of now unneeded '--mandir' configure flags.
This has become redundant with the 'validate-documentation-location' phase introduced in commit d68fe74. * gnu/packages/compression.scm (bzip2): Remove 'fix-man-dir' phase. * gnu/packages/ncurses.scm (ncurses)[arguments]: Remove --mandir. * gnu/packages/pth.scm (pth)[arguments]: Remove #:configure-flags. * gnu/packages/tcl.scm (tcl)[arguments]: Likewise. * gnu/packages/xiph.scm (flac)[arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm24
-rw-r--r--gnu/packages/ncurses.scm7
-rw-r--r--gnu/packages/pth.scm9
-rw-r--r--gnu/packages/tcl.scm8
-rw-r--r--gnu/packages/xiph.scm7
5 files changed, 12 insertions, 43 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index f2736b9eb3..cda1984f6a 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
@@ -115,13 +115,7 @@ file; as a result, it is often used in conjunction with \"tar\", resulting in
(home-page "http://www.gnu.org/software/gzip/")))
(define-public bzip2
- (let ((fix-man-dir
- ;; Move man pages to $out/share/.
- '(lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion (assoc-ref outputs "out")
- (mkdir "share")
- (rename-file "man" "share/man"))))
- (build-shared-lib
+ (let ((build-shared-lib
;; Build a shared library.
'(lambda* (#:key inputs #:allow-other-keys)
(patch-makefile-SHELL "Makefile-libbz2_so")
@@ -171,20 +165,16 @@ file; as a result, it is often used in conjunction with \"tar\", resulting in
`(alist-cons-before
'build 'build-shared-lib ,build-shared-lib
(alist-cons-after
- 'install 'fix-man-dir ,fix-man-dir
- (alist-cons-after
- 'install 'install-shared-lib ,install-shared-lib
- (alist-replace 'configure ,set-cross-environment
- %standard-phases))))
+ 'install 'install-shared-lib ,install-shared-lib
+ (alist-replace 'configure ,set-cross-environment
+ %standard-phases)))
;; Native compilation: build the shared library.
`(alist-cons-before
'build 'build-shared-lib ,build-shared-lib
(alist-cons-after
- 'install 'fix-man-dir ,fix-man-dir
- (alist-cons-after
- 'install 'install-shared-lib ,install-shared-lib
- (alist-delete 'configure %standard-phases)))))
+ 'install 'install-shared-lib ,install-shared-lib
+ (alist-delete 'configure %standard-phases))))
#:make-flags (list (string-append "PREFIX="
(assoc-ref %outputs "out")))
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index de7e6f6721..0dbc583f79 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -99,11 +99,6 @@
,(string-append "--includedir=" (assoc-ref %outputs "out")
"/include")
- ;; By default man pages land in PREFIX/man, but we want them
- ;; in PREFIX/share/man.
- ,(string-append "--mandir=" (assoc-ref %outputs "out")
- "/share/man")
-
;; Make sure programs like 'tic', 'reset', and 'clear' have a
;; correct RUNPATH.
,(string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index ba5fb8216d..50385b14f8 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -37,12 +37,7 @@
"0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
(build-system gnu-build-system)
(arguments
- '(#:parallel-build? #f
- ;; By default, man pages are put in PREFIX/man,
- ;; but we want them in PREFIX/share/man.
- #:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "out")
- "/share/man"))))
+ '(#:parallel-build? #f))
(home-page "http://www.gnu.org/software/pth")
(synopsis "Portable thread library")
(description
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index d988249c4c..2de2624df4 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
@@ -63,12 +63,6 @@
"tclsh")))))
%standard-phases))
- ;; By default, man pages are put in PREFIX/man,
- ;; but we want them in PREFIX/share/man.
- #:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "out")
- "/share/man"))
-
;; XXX: There are a few test failures (related to HTTP, most
;; likely related to name resolution), but that doesn't cause
;; `make' to fail.
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 77b732ba35..e6700c4c27 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -202,12 +202,7 @@ OpenBSD's sndio.")
"1p0hh190kqvpkbk1bbajd81jfbmkyl4fn2i7pggk2zppq6m68bgs"))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-tests? #f
- ;; By default, man pages are put in PREFIX/man,
- ;; but we want them in PREFIX/share/man.
- #:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "out")
- "/share/man"))))
+ `(#:parallel-tests? #f))
;; FIXME: configure also looks for xmms, input could be added once it exists
(inputs `(("libogg" ,libogg)))
(synopsis "Free lossless audio codec")