summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-07-08 22:31:48 +0100
committerMarius Bakke <marius@gnu.org>2020-07-21 00:58:02 +0200
commit0a62d25bb2ef3210c7030cc9b07e9bc14d512ad7 (patch)
treefed08b2ff7b5bebf6a03e4690ce8f0e6484ce136 /gnu/packages/music.scm
parentc82d5092f11e27d1c6683999e3d624f35f814285 (diff)
downloadguix-patches-0a62d25bb2ef3210c7030cc9b07e9bc14d512ad7.tar
guix-patches-0a62d25bb2ef3210c7030cc9b07e9bc14d512ad7.tar.gz
gnu: Add bshapr.
* gnu/packages/music.scm (bshapr): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 02e3d279f0..9d77bdde09 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1250,6 +1250,26 @@ B.Choppr is the successor of B.Slizr.")
(home-page "https://github.com/sjaehn/BChoppr")
(license license:gpl3+)))
+(define-public bshapr
+ (package
+ (inherit bsequencer)
+ (name "bshapr")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BShapr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jlq5rjicc4fxlpk869dg0l5bwwz8k9aj2wfk9v89b0qw8l8kaxl"))))
+ (synopsis "Beat/envelope shaper LV2 plugin")
+ (description "B.Shapr is a beat/envelope shaper LV2 plugin.")
+ (home-page "https://github.com/sjaehn/BShapr")
+ (license license:gpl3+)))
+
(define-public solfege
(package
(name "solfege")