summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-18 17:52:13 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-18 18:59:48 -0500
commiteb9d36670277f2206f87f50fa5186c482aa7fa12 (patch)
tree7f3b0a00038bc3e5685d4eb3be85c3b891762ce6 /gnu/packages/mp3.scm
parent559feb66618bbeca96ea5431522196d10951b378 (diff)
downloadguix-patches-eb9d36670277f2206f87f50fa5186c482aa7fa12.tar
guix-patches-eb9d36670277f2206f87f50fa5186c482aa7fa12.tar.gz
gnu: libmad: Add comment justifying the 'install-pkg-config phase.
* gnu/packages/mp3.scm (libmad)[arguments]: Add a comment about Audacity requiring a pkg-config file for libmad.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index c32b3cba11..916aa3e3b3 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -82,6 +82,10 @@
;; remove option that is not supported by gcc any more
(substitute* "configure" ((" -fforce-mem") ""))
#t))
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))