summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-18 18:53:48 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-18 18:59:48 -0500
commitac3c4e32474f226b7500d33605f43204a4c95466 (patch)
treec2c92efb26b813350e4be363c634665e9236c300 /gnu/packages/mp3.scm
parenteb9d36670277f2206f87f50fa5186c482aa7fa12 (diff)
downloadguix-patches-ac3c4e32474f226b7500d33605f43204a4c95466.tar
guix-patches-ac3c4e32474f226b7500d33605f43204a4c95466.tar.gz
gnu: libid3tag: Add comment justifying the 'install-pkg-config phase.
* gnu/packages/mp3.scm (libid3tag)[arguments]: Add a comment about Audacity requiring a pkg-config file for libid3tag.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 916aa3e3b3..34390d3696 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -131,6 +131,10 @@ This package contains the library.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))