summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-25 10:20:55 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-26 15:57:27 +0000
commita9291a28b233dba20a523da679bb446643abf977 (patch)
treec09285e27d7eca3af033987710a82b160cbca260 /gnu/packages/maths.scm
parent24b233d45c2a04a7a011397234b29fd5d7133110 (diff)
downloadguix-patches-a9291a28b233dba20a523da679bb446643abf977.tar
guix-patches-a9291a28b233dba20a523da679bb446643abf977.tar.gz
gnu: netcdf: Update to 4.7.4.
This will fix an issue building qgis. * gnu/packages/maths.scm (netcdf): Update to 4.7.4. [source]: Remove the netcdf-tst_h_par.patch, also change the naming of the source tarball, as the name seems to have changed for recent releases. [inputs]: Update hdf5 and add curl. * gnu/packages/patches/netcdf-tst_h_par.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove deleted patch.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f7565dd885..d2631501aa 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1538,17 +1538,17 @@ similar to MATLAB, GNU Octave or SciPy.")
(define-public netcdf
(package
(name "netcdf")
- (version "4.4.1.1")
+ (version "4.7.4")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.unidata.ucar.edu/pub/netcdf/"
- "netcdf-" version ".tar.gz"))
+ (uri (string-append
+ "https://www.unidata.ucar.edu/downloads/netcdf/ftp/"
+ "netcdf-c-" version ".tar.gz"))
(sha256
(base32
- "1blc7ik5yin7i0ls2kag0a9xjk12m0dzx6v1x88az3ras3scci2d"))
- (patches (search-patches "netcdf-date-time.patch"
- "netcdf-tst_h_par.patch"))))
+ "1a2fpp15a2rl1m50gcvvzd9y6bavl6vjf9zzf63sz5gdmq06yiqf"))
+ (patches (search-patches "netcdf-date-time.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("m4" ,m4)
@@ -1556,10 +1556,8 @@ similar to MATLAB, GNU Octave or SciPy.")
("graphviz" ,graphviz)))
(inputs
`(("hdf4" ,hdf4-alt)
-
- ;; XXX: The 'tst_nccopy4.sh' test fails when using hdf5-1.10.
- ("hdf5" ,hdf5-1.8)
-
+ ("hdf5" ,hdf5)
+ ("curl" ,curl)
("zlib" ,zlib)
("libjpeg" ,libjpeg-turbo)))
(arguments