summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm18
-rw-r--r--gnu/packages/patches/netcdf-date-time.patch6
-rw-r--r--gnu/packages/patches/netcdf-tst_h_par.patch21
4 files changed, 11 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1a01360d72..0ada3b727b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1355,7 +1355,6 @@ dist_patch_DATA = \
%D%/packages/patches/m4-gnulib-libio.patch \
%D%/packages/patches/ncompress-fix-softlinks.patch \
%D%/packages/patches/netcdf-date-time.patch \
- %D%/packages/patches/netcdf-tst_h_par.patch \
%D%/packages/patches/netpbm-CVE-2017-2586.patch \
%D%/packages/patches/netpbm-CVE-2017-2587.patch \
%D%/packages/patches/netsurf-message-timestamp.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f7565dd885..d2631501aa 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1538,17 +1538,17 @@ similar to MATLAB, GNU Octave or SciPy.")
(define-public netcdf
(package
(name "netcdf")
- (version "4.4.1.1")
+ (version "4.7.4")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.unidata.ucar.edu/pub/netcdf/"
- "netcdf-" version ".tar.gz"))
+ (uri (string-append
+ "https://www.unidata.ucar.edu/downloads/netcdf/ftp/"
+ "netcdf-c-" version ".tar.gz"))
(sha256
(base32
- "1blc7ik5yin7i0ls2kag0a9xjk12m0dzx6v1x88az3ras3scci2d"))
- (patches (search-patches "netcdf-date-time.patch"
- "netcdf-tst_h_par.patch"))))
+ "1a2fpp15a2rl1m50gcvvzd9y6bavl6vjf9zzf63sz5gdmq06yiqf"))
+ (patches (search-patches "netcdf-date-time.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("m4" ,m4)
@@ -1556,10 +1556,8 @@ similar to MATLAB, GNU Octave or SciPy.")
("graphviz" ,graphviz)))
(inputs
`(("hdf4" ,hdf4-alt)
-
- ;; XXX: The 'tst_nccopy4.sh' test fails when using hdf5-1.10.
- ("hdf5" ,hdf5-1.8)
-
+ ("hdf5" ,hdf5)
+ ("curl" ,curl)
("zlib" ,zlib)
("libjpeg" ,libjpeg-turbo)))
(arguments
diff --git a/gnu/packages/patches/netcdf-date-time.patch b/gnu/packages/patches/netcdf-date-time.patch
index a4e7925aa1..0bdfc55299 100644
--- a/gnu/packages/patches/netcdf-date-time.patch
+++ b/gnu/packages/patches/netcdf-date-time.patch
@@ -3,9 +3,9 @@
@@ -13,7 +13,7 @@
#endif
- /* Tell the user the version of netCDF. */
+ /** @internal The version string for the library, used by
+ * nc_inq_libvers(). */
-static const char nc_libvers[] = PACKAGE_VERSION " of "__DATE__" "__TIME__" $";
-+static const char nc_libvers[] = PACKAGE_VERSION" $";
++static const char nc_libvers[] = PACKAGE_VERSION " $";
/**
- \defgroup lib_version Library Version
diff --git a/gnu/packages/patches/netcdf-tst_h_par.patch b/gnu/packages/patches/netcdf-tst_h_par.patch
deleted file mode 100644
index ac14a4c0a2..0000000000
--- a/gnu/packages/patches/netcdf-tst_h_par.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From a83702834938b23cc2e843589aa223e2024a7e6f Mon Sep 17 00:00:00 2001
-From: Orion Poplawski <orion@cora.nwra.com>
-Date: Tue, 29 Nov 2016 11:48:01 -0700
-Subject: [PATCH] Add missing #include "err_macros.h" to tst_h_par.c
-
----
- h5_test/tst_h_par.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/h5_test/tst_h_par.c b/h5_test/tst_h_par.c
-index c3da7f4..a419d55 100644
---- a/h5_test/tst_h_par.c
-+++ b/h5_test/tst_h_par.c
-@@ -11,6 +11,7 @@
- $Id: tst_h_par.c,v 1.15 2010/05/25 13:53:04 ed Exp $
- */
- #include <nc_tests.h>
-+#include "err_macros.h"
- #include <hdf5.h>
-
- /* Defining USE_MPE causes the MPE trace library to be used (and you